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BioTrace+ is a product of Mind Media B.V. for NeXus. © Mind Media B.V. The Netherlands. All rights reserved.
Intended use of this manual
Please note that this user manual only covers the use and handling of the technical functions of BioTrace+ software. It does not
deal with physiological or clinical applications. Nor is this user manual or the software intended to be a guide of how to use or
interpret the physiological signals, data or session results. For that kind of information, please refer to the relevant professional
literature and publications.
This manual assumes that the reader is familiar with all the basics of using a Microsoft Windows ™ operating system.
We have taken great care in creating this manual. However we are always interested in feedback on how we can improve the
manual or enhance our products. Remarks or suggestions are appreciated and can be send to: support@mindmedia.nl
Disclaimers and warnings
Please read the following warnings and disclaimers before using BioTrace+ software:

-

-

-

Read this user manual and the NeXus hardware manual carefully before using BioTrace+ with NeXus-4, NeXus-10 or
NeXus-32.
The PC that is running BioTrace+ must be placed out of the clients reach for safety reasons. We advise 2 meters or
more. Generic PCs and notebook computers are not medical devices and therefore may pose a hazard to you, the
client or others. If safety is a concern we advise to run BioTrace+ only on a medical grade PC that conforms with EN60601-1.
Microsoft Windows ™ operating system is not a medical device. Computers running Windows ™, although
increasingly more powerful every year, may fail unexpectedly in terms of hardware and software for various
reasons. BioTrace+ software was designed with state of the art software development tools, but it cannot be
guaranteed it will run error free under all conditions. This poses the risk that data, signals or statistics may be
represented incorrectly, become invalid or data may get lost. Therefore we urge to make regular backups if
maintaining the data for the long term is important.
The operator is responsible for the safety of any device (including the computer, printers, accessories and other
attached apparatus) that is used by the BioTrace+ Software or attached to the computer that is running BioTrace+.
This software should never be used for diagnostic purposes, vital monitoring or for life supporting systems.

Limitations of liability
Insofar as is maximally permitted under the applicable prescriptive law, neither Mind Media B.V. nor its suppliers or resellers
are liable under any circumstances for any indirect, exceptional, incidental or consequential damages arising from the use of
BioTrace+ software or from the inability to use it, including (but not restricted to) the damage arising from loss of goodwill,
work interruption, computer defects or faults, or any other damage or losses consequential upon business interruption, even if
the possibility of these occurring had been mentioned and irrespective of the legal or impartial theory (agreement, unlawful act
or otherwise) on which the losses are based.
In any case and pursuant to any of the provisions of the present agreement, the total liability of Mind Media B.V. is limited in its
entirety to the sum of the price that was paid for this product and the fee for the product support granted by Mind media
under a (possible) separate support contract, with the exception of death or personal injury arising from negligence by Mind
Media B.V. insofar as the applicable prescriptive law forbids limitation of damages in such cases. Mind Media B.V. cannot be
held liable for the consequences of any incorrect information furnished by its staff or for any errors in this user guide and/or
other accompanying documentation (including trade documentation).
The other party (the user of the product of his or her representative) must hold Mind Media B.V. harmless and indemnify it
against any third party damages, irrespective of their nature and irrespective of the relationship with the other party.
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1. Basics
Installation
System requirements
The system requirements for BioTrace+ are:
- Windows® 8.1 Professional, Windows® 7 Professional, with Service Pack 1or
Windows® 10 Professional. Use Boot Camp for Mac OS X.
- Intel i3/ i5/ i7 series processor
- 4 GB of RAM memory or more
- Graphics card with 256 MB memory or more
- HD+ (1600 x 900) or Full HD (1920 x 1080) screen resolution
- USB 2.0 port
- Bluetooth 2.01
Additional requirements:
- Secondary monitor for optimal use of dual screen mode
- DVD-ROM drive for installation of BioTrace+2 or DVD-feedback
- Broadband internet connection for software updates and access to online services
1.
2.

rd

It is required to use a Microsoft Windows Bluetooth Stack and not a 3 Party Bluetooth Stack.
In case no DVD drive is available, please contact the reseller for more information about installation.

BioTrace+ setup
Insert the BioTrace+ DVD in to the drive and run setup.exe

It is recommend to install BioTrace+ in a root directory such as 'C:' or 'D:'.

The Welcome screen of the installer will appear.
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Click Next and follow the instructions for installation.
Please read the license agreement and select I agree and click Next.

Select an installation folder and click Next to continue.

Click Start to install BioTrace+.
The driver installation will start automatically. This could take a couple of minutes.
When installation has completed, click Exit.
Installing updates
Download the latest version at the Software Updates section of the Mind Media website
www.mindmedia.info/support/software-updates
Or by clicking Help > Internet: BioTrace+ Updates in the top menu of BioTrace+.
Please contact the reseller for more information about offline installation.

An update will improve and add functionality but it will also update screens, images,
feedback content, channel sets etc. An update is language specific.
Perform the following steps to install an update:
1. Download an update by right clicking the link and selecting Save target as.
Make sure to select to correct language.
2. Choose a location for saving the .exe file. It is recommended to save it on the
desktop. Close BioTrace+ before starting the installation.
3. Run the .exe file.
An update overwrites default content. Make sure to back up changed default content (e.g. edited
screen) before installation. Content with different names than default content, will not be overwritten.
Updates will not make changes to any session or client data.

4. The program will scan for installed versions of BioTrace+. In case of multiple versions
installed, please select the folder which needs to be updated.

Click Next to start the installation.
5. Click Exit when the update process is ready. The update is installed.
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Connecting the NeXus
There are two ways of connecting the NeXus to a computer:
1. USB connection (NeXus-10 and NeXus-32 only, please refer to hardware manual)
2. Bluetooth pairing
Bluetooth pairing
Make sure the Bluetooth dongle is connected to the computer.
When using an internal Bluetooth-dongle it is possible it needs to be activated manually using
shortcuts on the keyboard or a separate key / switch. As this varies for every brand and series, please
consult the machine's user manual.

Windows 8
Open the windows “charms bar” by moving the mouse to the right upper corner of the
screen, or by pressing the Windows key and C ( + C).
Click on Settings

Next click on Change PC settings in the right bottom of the screen. Click on PC and devices.
Click on Bluetooth.
Switch the NeXus on. Windows will search for the device. Select the device and click Pair.

The passcode for the device are the last 4 digits of the serial number which is displayed on
the ‘Enter the passcode for your device’ screen.
The serial number can also be found on the back of the device.

Enter the last 4 digits of the serial number and click Next. The device will be added to the
computer.

1. Basics

9

Definition of Bluetooth states:
- ‘Ready to pair’: The NeXus is not paired with the PC
- ‘Connected’: There is active communication between the PC and NeXus.
- ‘Not Connected’: The Nexus is correctly paired with the PC, but there is no active
communication with the PC.
It is recommended to restart the computer after Bluetooth pairing.

Windows 7
Locate the Bluetooth icon in the Windows® taskbar, usually at the right bottom of the
desktop (if not, click the arrow
to show hidden items).

Right click the Bluetooth icon and select Add a Device.

Switch the NeXus on. Windows will search for the device. Select the device and click Next.
The pairing code for the device are the last 4 digits of the serial number which is displayed
on the right side of the ‘add a device’ screen.
The serial number can also be found on the back of the device.

Enter the last 4 digits of the serial number and click Next. The device will be added to the
computer. Click Close to finish the Bluetooth pairing.
It is recommended to restart the computer after Bluetooth pairing.
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Dual monitor setup
Configuring the secondary monitor needs to be performed in Windows®.
Make sure to plug in the secondary monitor first. A beamer or a television can also be used.

Right-click on the desktop in Windows and select Screen resolution.

The display settings menu will appear.
Choose Extend these displays under Multiple displays for using the secondary monitor.

Shortcut for changing displays
Press the Windows key and P (

Windows 8

+ P) to bring up a quick menu of options:

Windows 7

Activating BioTrace+
Connect the NeXus to the computer.
For more information about connecting the NeXus, please refer to the previous paragraph

Start BioTrace+ by double-clicking on the BioTrace+ icon on the desktop or browse to the
BioTrace folder and open BioTrace.exe.
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The Introduction screen will appear.

Click Continue. The Sign In screen will appear.

Create a new Mind Media account online by clicking Sign Up
Alternatively go to our website: www.mindmedia.info/support/account-registration

Please fill in your contact information and choose a password. Click Sign Up to create your
free account.
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You will receive an email to validate your email address which will be used as the contact
email address for your account.
Please confirm your contact information by clicking the link in this email.

Now enter your contact email address and your password in the Sign In screen of BioTrace+.

Click the Activate button.

If you have successfully activated the BioTrace+, an alert box will appear.

Your NeXus can be used to activate BioTrace+ on 4 computers per year. If you wish to activate
additional BioTrace+ installations, please contact support or your reseller.

Offline activation
If your computer is unable to connect to the internet the Offline Activation screen will
appear. You can also manually activate offline by clicking the button “Offline Activation”.
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Send the Request Key and your contact email address to support@mindmedia.nl to receive
an Activation Key. Fill in this Activation Key and click Activate in order to activate BioTrace+.

Navigation
Home menu
At the startup of BioTrace+, Home will appear.

Home contains the following items:
Choose between various types of signals or modalities.
This library provides a series of protocols for specific
biofeedback and neurofeedback applications.
This library provides psychophysiological stress profiling
protocols and stress assessment protocols.
Browse client information and review sessions
Browse all screens which are available.
Open favorite screens
Select a signal or modality in the Signal Library
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Every category consists of several training and data acquisition screens. These screen types
are marked by the following icons:
Training
Data acquisition
Training screens
Every training screen includes one therapist screen with several client screens.
A therapist screen provides all controls for setting feedback.
A client screen provides the specific feedback for the client. Every therapist screen contains
several different types of client screens.

Training - Therapist screen

Training - Client screen(s)

It is recommended to use a dual monitor setup for the best user experience.
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Monitoring screens
Monitoring screens are not intended for training but can be used for physiological
monitoring. Every category in the Signal Library contains one or more monitoring screens.

Monitoring

Monitoring screens are not linked to client screens.
Toolbar
The Toolbar is located at the top of BioTrace+.

The toolbar contains the following buttons:
Back to previous screen
Home
Open Client Database
About...
Connecting...
Signal check
Help button. Descriptive text will appear in a text box when moving the
cursor over the buttons.
Session Control Bar
The Session Control Bar is placed at the bottom of every training screen. With these buttons
it is possible to control a session.
1

2

1.
2.
3.
4.
5.
6.
7.
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4

5

6

7

Open Screen Browser
Session Overview/ Real-time mode
Add marker
Play/ replay session
Stop session
Pause session
Record session
16
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9

8.
9.
10.
11.

10

11

The time display of a session
Go to start of session
Slide session
Go to end of session

Feedback Controls
Feedback can be controlled with action buttons. Actions can be starting a protocol or loading
a feedback screen. BioTrace contains the following types of feedback controls:
- Frequency Band Controls
- Feedback & Threshold Controls
- Client Feedback Type Controls

Frequency Band Controls

Feedback & Threshold Controls

Feedback Type Controls

For more information about using the action buttons, please refer to Chapter 3. Feedback.

Top menu
The top menu is always available at the top of the screen and contains the following items:

Build New Screen

Create a new screen by opening the screen editor

Save Screen

Save screen with same name on the same location

Save Screen As...

Save screen as a copy or to a different location

Load a Screen

Open a screen with the Screen Browser

Open Session/ Database

Open a session with the Client Database

Save Channel Set as...

Save a channel set as a copy

Load Channel Set

Load a channel set

Print...

Print a data report

Print Preview

Open a print preview

Print Setup

Open printer settings

Export Session Data

Export multiple data channels in multiple formats

Exit

Exit the program

Edit Screen

Edit a screen by opening the Screen Editor

Edit Sequence Script

Define a fixed sequence of screens

Grid

Set the resolution of the grid in the Screen Editor

Show Full Screen

Enable full screen mode
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Show/Hide Control Buttons

Show or hide the Session Control buttons

Copy Primary > Secondary

Duplicate primary screen to secondary screen

Copy Secondary > Primary

Duplicate secondary screen to primary screen

Close Secondary

Close secondary screen

Session Overview

Switch between Session Overview and Real-Time mode

Sensor Input Config

Open the Sensor Input Configuration

Channel Set Config

Open the loaded channel set

Channel Freq Control

Open the Frequency Control Panel

Z-Score Configuration

Open Z-Score Configuration

System Settings

Open System Settings

Color Scheme

Open Color Schemes

Multimedia DVD Control

Open Multimedia DVD Control

RSP/HRV Pacer Settings

Open Pacer Settings

FFT Analysis Settings

Open FFT Analysis Settings

This menu is only available for NeXus-32.

This menu is only available for NeXus-10 and NeXus-32.
Build New Presentation

Open the ERP/EP Event Presentation Builder

Edit Presentation

Open the Event Presentation Editor

Load Presentation

Load a presentation

ERP/EP Averaged Response

Perform ERP/EP Averaged Response Analysis

This menu is only available for NeXus-10 and NeXus-32.
Build New Trial Sequence

Build new trial in Trial Configuration

Edit Trial Sequence

Edit trial in Trial Configuration

Load Trial Sequence

Load trial

Trial Analysis/ Report

Open Averaged Response Analysis

Tutorial Videos

Videos which explain functionality of BioTrace+.

Software Manual

Show BioTrace User Manual

Keyboard Shortcuts

Open Keyboard Shortcuts overview

NeXus User Group (US)

Open User Group for support (EN)

NeXus User Group (DE)

Open User Group for support (DE)

NeXus products

Show NeXus by Mind Media products

BioTrace Updates

Show latest version of BioTrace

What's new

Show What's New document
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Activation & Registration

Show status of activation

About BioTrace

Show more information about BioTrace version

Shortcuts
Shortcuts are a quick way to access the main functions. These shortcut actions are:
Screen actions
Load a screen in the Screen Browser
Go to Main Menu (and back)/ Exit screen
Switch to Session Overview (and back)
Enter/exit full screen mode
Show secondary screen on primary monitor
Show primary screen on secondary monitor
Screen shortcuts (user defined)

Shortcut
L
Esc
Tab
F
Shift + <
Shift + >
F1 - F12

Object actions
Select Video Files screen
Multi-media: DVD Navigation screen
Decrease smoothing of signal

Shortcut
V
M
Shift + S

Editing actions
Edit screen
Refresh screen
Edit script in the Screen Sequence Editor
Save screen
Copy an object
Paste an object
Undo changes

Shortcut
E
R
Q
Ctrl + S
Ctrl + C
Ctrl + V
Ctrl + Z

Session actions
Open a session in the Client and Session Database
Start a recording
Pause, play in replay mode
Add event marker
Auto event marker
Frequency Control Panel screen

Shortcut
O
Enter
Spacebar
Enter
Spacebar
Shift + C

Feedback actions
Z-Score Configuration screen
Toggle threshold visible/invisible
Toggle threshold active/not active

Shortcut
Z
[
]

Analysis actions
Print data report
Segment Marker Shortcut Keys screen

Shortcut
P
Y

Channel actions
Input configuration in the Sensor Input Configuration
Channel selection in Select Channels

Shortcut
I
C

Increase smoothing of signal
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Client Database
The Client Database is database where all client and session data is stored. In this database it
is possible to manage client data and open previously recorded sessions.
Click the following button in the top menu:

This will open the Client Database.

The Client Database contains the following features:
Add new client

Open session

Delete client

Delete session

Edit client

Rename session

Open client report

Session notes
Trend reports
Import sessions
Export sessions
Clinic information

More information about managing sessions in the Client Database, please refer to chapter 2. Sessions
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Adding and editing clients
When adding a new or editing a client, the Client Information screen will appear.
or

Fill out or edit all available information about the client. At least the Last name and First
name fields have to be filled out. Click the OK button to save the client information.
Click the following button to delete a client:

Be aware though that by deleting a client, all the client information, including all the sessions will be
deleted.

Check Client Confidentiality above the client overview on the left.

This will mask client names.
Creating a client report
Click the following button for creating or editing a client report:

This will open the Client Diagnostic Report screen.
In this screen additional information of the client can be added or edited, like:
- Symptoms
- Diagnoses
- Clinical suggestions
- Training protocol
- Treatment channel
- Evaluation
- General notes
Click Print report to print the client report.
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Edit clinic information
Click the following button in the Client Database:

This will open the Clinical Management screen.

Enter therapist information and clinic information. This information will show up when
printing reports.
To add a new therapist, select the New Therapist button.

Reports can be created with an own logo. By putting the logo in to the BioTrace+ Folder
..\BioTrace\Images., the logo can be chosen from the drop down menu on the right bottom.
Make sure to name the logo Logo<number>, e.g. logo1, logo12. For an optimal result, the
size of the logo should be 450 x 450 pixels.

Screen Browser
The Screen Browser contains all available feedback screens in BioTrace+. Open the Screen
Browser by clicking the following button on Home:

Alternatively by clicking the Screen Browser button in the Session Control Bar.
1. Basics
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Add new category*

Load screen as primary screen

Rename category*

Load screen as secondary screen
Save screen

*Only applicable for My Screens

Delete screen
Bookmark screen to favorites
Show help text
The Screen Browser contains two main categories:

My Screens display your own screens. It is possible to add new categories and to rename an
existing category. BioTrace+ Screens show all screens which are available in BioTrace+.
Choose between the several libraries or favorites. Choose a category from the left side of
the browser.

Open a screen by selecting the screen and click the following buttons:
for loading as primary screen
1. Basics
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Add screens to favorites
Select a screen in the Screen Browser.

Click the following button for bookmarking the screen to favorites.

Enter the name for the screen and click OK. The screen has now been bookmarked as
favorites.
Open Favorites on the Home screen or restart the Screen Browser in order to start using the
bookmarked screen.
Shortcuts
It is also possible to assign a function key (F1-F12) to a screen. Select a screen and press one
of the function keys (F1-F12). Press the K key for an overview of the shortcuts. The defined
shortcut can be found on the right side of this window. Hold the Ctrl for loading this screen
as a secondary screen.

Session Overview
Session Overview is used to view or review data and perform (offline) analysis.

This will open the Session Overview.

Switch back to Real-Time mode by clicking the following button in the Session Controls:
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Alternatively press the Tab key to quickly switch between both (or by clicking Screen >
Session Overview in the top menu).
It is also possible to switch between modes during a recording.
For more information about data analysis, please refer to 4. Review and 5. Analysis & Reporting.

Settings
System settings
Open the System Settings by selecting Configuration > System Settings in the top menu.

Select Use data directory option for data storage on a networked drive. In that case several
computers will be able to have access to the same database. Browse for a database.
Please refer to 2. Sessions for more information about session backup.

The Battery-low warning option enables an alert when the battery of the device turns low
during operation. This option is enabled by default.
The Output live data option can be enabled for storing output data in
'\BioTrace\System\DataChan.bin'.
The extended database option shall be selected when using the database system
incorporated in BioTrace+ versions released prior to 2006.
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Printer: black & white. Enable this option for printing all reports in black and white.
The Intro sound can be disabled by checking this option. This mutes the intro and outro
sound during startup and exit.
The Bandpass DC correction option sets bandpass correction. Choose one of the following
options:

Select the Language of all menus and screens. Choose between (other languages may be
available):

The option Select Screen Selection Strategy sets which screens are visible in the screen
browser and the routing/menu buttons.

-

Show All screens shows all screens available for this instance of BioTrace+.
Show selected language only shows only screens from the selected
language.
Show latest version shows the screens with the highest available version
number from the own or the English language.
Show selected language preferred shows screens from the own or the
English language with a preference for the own language, regardless of
the version number of the English screen. This last option is the default
option in BioTrace+.

The Session recording time option sets the recording maximum session recording time.
Choose between the following time settings:

With the Font settings option font size of objects on therapist screens can be adjusted.
Choose between not applicable (default), 10, 12, 14, and 18.

The Tooltip option enables the tooltip when hovering over objects.
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The MIDI Sound Set option allows choosing between the default MIDI set and User MIDI set.
The User MIDI set allows to create a custom MIDI set of up to 16 MIDI channels, selectable
from 128 available MIDI instruments.

Color schemes
The Color schemes enable to load different color layout of the therapist and client screens.
Open the Select a color scheme screen by selecting Configuration > Color Scheme in the top
menu.

Disable the color scheme <<Disable Color scheme>> to leave the screens in the original color
set. Color schemes are disabled by default.
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Disable Color scheme/ default color settings

Select one of the various color schemes, and click OK to apply the scheme for all therapist
and client screens.

Dark-2.colorscheme enabled

Check Include My-Screens for enabling a color scheme to all available screens in My Screens.
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2. Sessions
This chapter describes recording sessions and how to store client data.
Refer to applicable hardware manual for additional information.

Starting a session
Start a session by using one of the following libraries on the Home menu:

Alternatively start a session with the Screen Browser. Please refer to 1. Basics.

Select a screen in the list. A preview is shown when hovering over a button.

Now the screen is loaded. Use the Toolbar getting more information about the signal, learn
how to connect the hardware, or perform a signal check.

Recording a session
It is not possible to start a recording if the NeXus is not paired to the computer. Always make sure the
device has sufficient power before starting a recording.

Click the Record button of the Session Control Bar at the bottom of the screen, to start a
recording.
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The Select a client dialog box will appear.

Select a client and click Continue...
Note that client information can be edited in the Client Database.

The New session recording screen will appear. The computer starts the connecting to the
NeXus.

Click Start recording to start recording a session.
To create a new client, click the Add new button in the Select a client screen.
The Client Information screen will appear. Fill out at least a Last name and a First name. Click
OK to save the new client.
Pausing a session
In order to pause a recording, click Pause in the Session Control Bar.
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Saving a session
In order to stop a recording, click Stop in the Session Control Bar.

An alert box will appear.

Click Yes to save the session and to enter a description of the session.

Confirm by clicking OK, the session is now saved.
Click Continue... to continue recording the session.
Click No to end the session without saving it.
It is possible to rename or delete a session in the Client Database. Please refer to chapter 1. Basics.

Adding markers
Markers can define a certain event during a recording. These markers can be added
manually by pressing the following button in Session controls (or by pressing Enter):

The following dialog box appears for naming markers.

It is also possible to set automatic consecutive numbering (1, 2, ..) markers by pressing Space
bar. Markers by using 'space bar' or 'enter' will show up as a dotted line in the session
overview screen.
Please note that the marker is set at the exact time the ‘space bar’ or ‘enter’ key are pressed.
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Use the NeXus device for adding markers or triggers:
- NeXus-4 and NeXus-32: Press the on/off button
- NeXus-10: Press the marker button
Markers generated by NeXus will show up as a straight pink line in the session overview
screen.
For more information about markers, please refer to chapter 4. Review

Opening a session
Click the Client Database button in the Top Menu for opening a session

Or go to File > Open Session/Database in the top menu.
Select a client on the left side. All sessions of this client are shown on the right.
Open a session by clicking the following button:
or by double clicking the session.

'John Sample' is a sample client with prerecorded sessions.

If a screen has not been loaded yet, a dialog box will appear. Click Yes to load a screen in the
Screen Browser.
Select a screen which can display the recorded data, like an EMG screen for a session that contains
EMG data.

Replaying a session
Click the Play button of the session control buttons for reviewing a session.

Press the Stop button for stopping the replay.
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The time slider can be used during review mode only, to scroll through the session.

Click inside the scrollbar and move the scrollbar while holding (dragging) the scrollbar. This
function only works in case a session has been loaded.
Another way to navigate is by using the session control keys:
- Left cursor (arrow) key: steps back 1 second
- Right cursor (arrow) key: steps forward 1 second
- Page-Down key: steps forward 5 seconds
- Page-Up key: steps back 5 seconds
Holding the Ctrl key down while using the cursor keys, will step through the session in steps
of 50 milliseconds.

Editing sessions
It is possible to edit sessions in the Client Database.
Deleting sessions
Delete one or multiple sessions by clicking the following button

Renaming sessions
Rename a session by selecting a session and clicking the following button

Enter a description and click OK
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Adding session notes
Click the following button for adding or editing session notes:

Add a description and enter session note text. Click OK for adding the session notes.

Backing up sessions
Store data on networked drive
With data storage on a networked drive several computers will be able to have access to the
same database.
Click Configuration > System Settings in the top menu. This will open System Settings. Check
the following box:

A dialog box will appear for entering the network drive.

After clicking OK a *.mdb file can be selected. Click Open to store data in this selected file.
The entire folder Data will have to be moved to the networked drive in order to perform this
procedure.

Exporting sessions
Open the Client and Session Database, select a session from a client and click the following
button:
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This will open the Wizard Export Sessions.

Choose between the following options:
- Export the selected session
- Export all sessions for the selected client
- Export the entire database
- Export a custom selection.
The first three options will export directly to *.bcd file. Select an option and click Next. Click
the Save button to export a session.
Select Export a custom selection for more options. This will open the Export Sessions screen.
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It is possible to select multiple sessions and/or clients. Edit Export Settings for advanced
options like client confidentiality, raw data only, include trend reports, and exclude
video/audio. Click Export for exporting the selection to a *.bcd file.

Importing sessions
Open the Client and Session Database and click the following button:

This will open the Wizard Import Sessions screen.

Import exported session
Select Import / Restore earlier exported session(s) to import a previous exported session.
Click the Next button. An alert box will appear.
Click OK and select a *.bcd file. Click Open. The Wizard Import Session screen will appear.

Select a client or create a new client from the drop-down menu. Click Next >> to import the
file.
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Import from flash memory for NeXus-4
Import ambulatory sessions by selecting Import ambulatory sessions from Flash Memory.
When this option is not available, make sure that the latest driver is installed.

This will open the Import flash screen.

Select one or more sessions and click the Import Selected Sessions button to import the
session into the Client and Session Database.

Import from flash memory for NeXus-10/NeXus-32
Import ambulatory sessions by selecting Import ambulatory sessions from Flash Memory.
This will open the Import flash screen.

Check Convert to .bin file if needed
BioTrace+ can handle ambulatory session of up to 24 hours. Ambulatory sessions that are longer than
24 hours need to be converted to .bin files which will present the data as arrays of float values.
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Select one or more sessions and click the Import Selected Sessions button to import the
sessions into the Client and Session Database.

Please note that after importing an ambulatory session you need to recompute the session overview in
order to assign the virtual data channels to your sensor input channels.
Open the desired client screen where the recorded data has to be displayed.
Load the ambulatory session via the Client and Session Database and switch to the overview screen.
Click right mouse button in the overview screen, select Recompute Session Overview and click Yes
twice to recompute and save the session.

Z-Score
Read the Z-Score white paper for more information about how to use Z-Score. Visit our
website (http://www.mindmedia.info/support/technical-whitepapers) for an overview of
the latest white papers.
Configuring Z-Score
Go to the top menu and select Configuration > ZScore Configuration (or press the Z key).

This will open the Z Score Configuration and Channel Selection.
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Select EEG channels 1 to 4 with the related electrode position. It is also possible to select age
and condition (eyes closed or open).
Activating Z-Score
Click the buttons at the bottom of the Z Score Configuration and Channel Selection screen for
registering Z-Score.

Read the license agreement and accept this agreement. This will generate a security key
called 'Security Key A'.

Mail this 'Security Key A' to the supplier. After receiving 'Security Key B', enter this key and
click OK. Z-Score will now be activated.
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3. Feedback
This chapter describes the feedback settings during a session.

Types of feedback
Selecting feedback
There are several types of feedback which can be selected on a therapist screen. This can be
performed by the Feedback Type Controls on the right of a training screen:
Graph

Water ripple

Video

Clock

Puzzle

Zoomer

Animation

Mandala

Game

Protocol

Disc
Audio
Change feedback content
Select other content during a recording by clicking the change feedback button on the top.
This can only be performed for videos, animations, games, puzzles, and audio.

For each type of feedback a selection window will appear. This enables to select other
feedback content for the client screen.
For more information on videos, animations, puzzles, and audio files, please refer to chapter 6. Objects

Setting thresholds and feedback
Threshold modes
The threshold setting controls are displayed on the right of a bar graph:
Manual threshold
Automatic threshold
Disable threshold
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Use the Feedback Options & Thresholds menu for custom settings. Please refer to the next
paragraphs.

Manual threshold
Set a manual threshold by clicking the following button:

The threshold can be set by swiping the bar to the right value with the mouse cursor.

Automatic threshold
Set an automatic threshold by clicking the following button:

When the automatic threshold type is based on statistics (see Advanced threshold options) the AT
(Automatic Threshold) button will appear in the %Success indicator

By pressing the AT button you are able to select the desired (success) target for the automatic
threshold from a list with steps of 5% increments.
Please note that when you change the direction of training while the automatic threshold is activated,
you need to reset the automatic threshold to the desired target.

Disable threshold
Disable thresholds by clicking the following button:

A dotted line means that no feedback options have been set for this object. A solid line
means that feedback options have been activated.

Feedback enabled

Feedback disabled

The ] key can also be used to the enable or disable feedback. To show or hide the threshold line press [.
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Threshold directions
The threshold direction controls are displayed on the right of a bar graph:
Train up
Train down

The graph will show an arrow to indicate which direction is set.

Hide/show graph
It is possible to hide and unhide the bargraph feedback on the client screen
Show graph on client screen
Hide graph on client screen

If bar graphs are hidden, feedback settings are not activated on the client screen.

Hide/show/reset counter
Control counters on the therapist and client screens. The counter controls are located in the
bottom right corner of a screen:
Show counter on client screen
Hide counter on client screen
Reset counter
Advanced threshold options
By right-clicking an object and choose Feedback Options & Thresholds in the drop down
menu.
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The Biofeedback and Threshold Settings dialog box will appear.

Enable/unable feedback
Enable thresholds and feedback settings by checking Enable Biofeedback at the bottom.

Un-check to disable all feedback by the object.
Setting manual threshold level
Set a value for a manual threshold under Threshold 1 Level. Thresholds can be locked by
checking Lock Threshold. In this case the threshold will stay fixed.

When right clicking within a line graph or bar graph object, a threshold line will appear.

Setting automatic threshold level
By checking On for first an automatic threshold can be set for a set time in minutes. After
the set time in minutes the threshold will automatically stop, representing the last
calculated value.
The automatic threshold is based on either 15 or 30 second statistics or is a slow or fast
running average.
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Target percentage will create a threshold in which the value will be a percentage of the time
above threshold.

Setting threshold 2 level
A second threshold can be set when checking Enable Threshold 2.

Note that when enabling the second threshold, the settings for In-between thresholds will be
activated. Threshold 2 should always be below threshold 1.
Forward threshold changes
By checking Forward Threshold Changes all objects showing the same signal will have the
same threshold as this object.

Setting a counter
A counter can be set for showing scoring above, in-between, or below thresholds. A
numerical indicator will have to be present and set for scoring to become visible.
Right-click a numerical indicator, choose Display Options & Ranges and display a counter
value in order to show scoring.

Required time (ms) defines how long a threshold condition should last, before the feedback
starts, a feedback delay (e.g. setting it to 1000 ms, means that feedback will start whenever
the feedback condition has been met for at least 1 second).
The reward-tag can be used in combination with the Show %reward function which can be
set in the Display Options and Range Settings screen under Data Type/Stats.

A counter can be shown by a numerical object. Refer to Chapter 5. Objects.

Adding a reward tag
Above and/or below threshold can be selected as reward. Check the box Reward-tag.

Bargraph objects can be set for up- or down training, or both by ticking the Reward-tag
checkbox in the Biofeedback and Threshold Settings dialog of the bargraph object.
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Advanced feedback options
Right-click an object and select Feedback Options & Thresholds.

This will open the Biofeedback and Threshold Settings dialog box.
Select one of the following feedback types for above, in-between, or below threshold(s).
Always enable feedback for setting audio feedback (see previous paragraph).

No feedback
The feedback type for each threshold state can be set on No feedback. This means no
feedback is set for above, in-between, or above a threshold states.

Inhibit all feedback
Inhibit all feedback is often used as a condition for an undesired state.

In case an inhibit state is active all audio and visual feedback will be ‘paused or stopped’
until the inhibit state goes away. It does not matter in which screen (primary or secondary)
the inhibit is activated.
An inhibit state is indicated by a red background in the time display of the session control
buttons.

Check Ignore Inhibit all for deactivating 'inhibit all feedback' of other objects.

The object will not respond to inhibits by other objects.
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Midi tone feedback
This option will play a tone, a chord or sequence of MIDI tones. Click Edit.

This will open the MIDI Tone Feedback Settings dialog box for setting the volume, type of
instrument and tone/melody settings.

Set the volume with the slider on the left from min. to max. Choose a musical instrument in
the middle column.
The available musical instruments can be customized in the System Settings

Check Use Repeating Single Tone to continuously play the tone in case the feedback
condition is met.

Instruments can be edited in the right column MIDI tone/melody settings.
Midi song feedback
Click Edit to select a song, change volume, loop songs, etc.
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This will open the MIDI song feedback settings dialog box.

Click <-- to move a song from Available songs (right) to Selected songs (left). Use the <--All to
select all available songs.
Click Play for a preview of the song. Click Stop to stop a preview.
Checking Loop Song(s) will keep on playing the midi-tone as long as the feedback condition
is met.

Change the order of the selected songs by selecting a song and clicking Up or Down.
CD audio feedback
It is also possible to play tracks from an audio CD. Insert an audio CD. The CD-drive will
automatically be detected.
Click Edit to select tracks, loop tacks, etc. It is not possible to change volume.

The functionality is the same as the option Midi Song feedback.

Increment reward counter
Above and/or below threshold can be selected as reward. Select Counter #1 / #8 by clicking
the following button.
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Digitized sound feedback
Click Edit to select a media file (WAV, MP3 or WMA), change volume, loop songs, enable
volume feedback etc.

This will open the Digital sound & song feedback settings dialog box.
Most of the functionality is the same as the option Midi Song feedback.

Check Enable Volume Feedback to use a special option that uses ‘fading in and out’ control
on your sound files.

Choose the Settings button for defining the volume feedback.

This will open the Volume Feedback Control Settings dialog box.

There are three settings which can be edited:
- Volume fading
o ... defined by start/end of Y-scale range will set the minimum volume at the
bottom of the y-scale. At the top of Y-scale the volume will reach its
maximum. The sound will only play above threshold so make sure the
threshold is towards or below the beginning of the Y-scale.
o ... defined by level above/below threshold will set the minimum volume at
the threshold and the maximum volume at a certain level (as a percentage
of the total range) above or below threshold. Set the range as a percentage
of the total range.
- Proportional feedback
o Proportional feedback will set response of the volume go up, when the level
goes up.
o Inverse proportional will set the response of the volume goes down when
the level goes up.
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-

Fade out range
o 24 dB defines volume level fading out to soft but still audible level.
o 60 dB defines volume level fading out to total silence.

Frequency bands and ranges
When clicking the Frequency Band Controls, the frequency range setting is pushed to the
linked objects. In this way it is easy to switch between different bands:

When clicking the Custom button, the custom frequency range setting is pushed to the
selected instruments.

The range of the frequency can be set by clicking the button next to it.

Respiration/HRV pacer
The pacer can be used for ‘pacing’ or training signals using a template wave-form
This option is only applicable for all screens with a respiration pacer.

Click the following icon to set the respiration pacer (or go to the top menu and select
Configuration > RSP/HRV Pacer Settings)
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This will open the Respiratory Pacer Settings screen.

Setting parameters
The following parameters can be set (time entered in milliseconds):
- T1 Inhale Time: the time it takes to go from baseline (0) to the maximum (inhale).
- T2 Sustain Time: the time the signal will be sustained (hold) at maximum.
- T3 Exhale Time: the time the signal will drop from maximum to baseline (exhale).
- T4 Pause Time: the ‘pause time’ in between this and the next cycle.
Based on these parameters, a pacer rate in breaths per minutes (BPM) will be calculated.
Click the + and - button to change the pacer rate while maintaining the same ratios.

Use the + and – keyboard keys during a session in order to speed up or slow down the pacer.
Check Bind pacer settings... to always have the same setting for the loaded screen.

This feature requires a pacer to be present in the screen. It is of no importance which type of object, as
long as it is connected to the pacer-input of the channel set.
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Setting automatic pacer
A pacer can be set to change over time with a preset start/end and with a pre-set step size.

Edit the following properties for setting up the automatic pacer.
- Auto-step function
 Disable automatic pacer
 Enable automatic pacer: auto-step every 1 to 10 minutes
- Auto-step size (BPM)
 Increase from start > end by 0.5 to 1.0 BPM
 Decrease from start > end by 0.5 to 1.0 BPM
- Start/end pacer values
Saving and loading pacer settings
Click Save (client) to save this pacer settings for the currently selected client. BioTrace will
auto-load these pacer settings every time this client is selected for a new recording.

Click Load (client) to load saved pacer settings for the currently selected client.
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4. Review
This chapter describes the data for analyzing sessions. Data can be viewed and edited in
Session Overview by clicking the following button in the Session Control Bar.

Or go to Screen > Session overview in the top menu (or press the Tab key).

Selecting data
Select data by clicking the left mouse button and dragging the mouse to the left or right.

A selected area

The selected data will be highlighted by a black background. When releasing the mouse
button, a drop down menu will appear, presenting several options.
It is recommended to use the x-axis (time) at the bottom of the screen for selecting data. This prevents
unwanted changes in the data, like moving segments.

Zooming data
Choose Zoom selected data after having selected data by left clicking and dragging the
mouse.

Another way of zooming in and out is by choosing the option Size of TIME axis when clicking
the right mouse button in the session overview screen mode. Choose the length of the time
axis from a drop down menu.

The time-axis can also be set by using the + and - keys on the numerical keyboard.
To zoom out, right mouse click and choose Time-axis <Fit Session>. Quickly zoom out by
pressing Backspace.
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Segments
Adding segments
Add specific segments in the session to distinguish different phases in a recording.
After selecting a part of the data, a segment can be defined by using the Add Segment
option.

There are several predefined segment types available, like baseline, train, stressor, relax etc..
These are distinguished by name and color.
Deleting segments
To delete a marked segment, select the segment by left clicking it. A selected segment will
show black ‘handles’ around it.

Right click and select Segment options: > Delete this segment (or left-click a segment and
press the Delete key).

A dialog box will appear. Press the Yes button to confirm deleting the segment.
When deleting a segment, only the segment will be deleted, not the actual data!

Locking segments
Protect segments for editing or deleting by right clicking and selecting Segment options: >
Lock Segments!

This can be done for just one segment by first selecting the particular segment. Or this can
be done for all segments together in the data by selecting no segment(s).
Just click this same option again to unlock segments for editing.
Defining and adding segment types
By right-clicking the screen and selecting Segment options: > Segment: Type definitions,
custom type definitions for segments can be added.
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The Definition of segment types screen will appear.

Enter a segment name in the text box and click Add segment type to add a new segment.
The new entry will be placed at the bottom of the list.
To attribute a color to a new or existing segment, first select the segment in the list and then
click on the color box on the right to select a color.
Select Delete type for removing a segment type.

Artifact areas
Manually marking artifact areas
Mark a new artifact area by selecting data, and choosing Segment: add Artifact area.

Artifact areas are special types of segments that mark a part of the session as being ‘invalid’.
These artifact areas will be excluded for analysis. The data in the artifact area will not be
deleted, it is only ‘marked’ as being artifact.
The Artifact segment will appear as a red cross hatched area.

Manually selected artifact area

Artifact areas can be removed just like segments.

Automatic artifact rejection
Enable automatic artifact rejection by right clicking the screen and open Automatic artifact
rejection > Enable rejection.

4. Review

55

One or two criteria for data rejection can be set. Whenever a signal meets a criterion, red
marks will appear just above the time axis.

Automatically defined artifact area

When marking a part of the data as an artifact area, data of all channels at that certain time point will
be marked as artifact and excluded in the analysis.

Event markers
Adding markers
To insert event markers after the data recording, right-click the screen and select Event
markers: > Add marker.

A text screen will appear.

Enter text and click OK.
A marker is shown as a black dotted line in the session overview mode.
Editing markers
Moving a marker
A marker can be moved when hovering the mouse over the dotted line. The cursor of the
mouse will transform into a cursor with two arrows.

Now move the marker by pressing the left mouse button and moving the mouse to the left
or right.
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Renaming a marker
Rename a marker by selecting it, pressing the right mouse button, and selecting Event
markers: > Rename marker.

Deleting a marker
Delete a marker by selecting it, pressing the right mouse button, and selecting Event
markers: > Delete marker (or by selecting a marker and press the Delete key).

Changing display of signals
Right-click the y-axis for changing the display of signals.

Setting the range
Change the Y-scale range by choosing YScale range.

The following options are available:
- Manual range: enter the range manually.
- Auto range 0-max: an automatic range with 0 as the minimum and the maximum
value of the signal as a maximum.
- Auto range min-max: an automatic range with the minimum value of the signal as a
minimum and the maximum value as the maximum.
- Inverse polarity: inverts display of line graphs
Display type
Change the display type by choosing Display type.

This option enables to select the graphical way the data is displayed:
- Lingraph (default)
- Linegraph with markers
- Bargraph 2D
- Bargraph 3D
Smoothing data
Set smoothing of the signal by Smoothing.
.
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Smoothing is an option that will ‘dampen’ a signal, in case it is rapidly moving up and down.
Setup smoothing with a factor 2 till factor 64. Smoothing is disabled by default. This option is
only available for line graphs.
Data Type/Statistics
Select the option Data type/statistics to change the way the data is processed before being
displayed.

Choose between the following options:
- Show RAW samples will show the unprocessed data.
- Base epochs on segment
- Show N second statistics will show a summary of data over N seconds to shows
trends in the data.
- Show <statistics> (e.g. mean) indicates which statistic will be used to summarize the
data.
Displaying thresholds
Display thresholds by choosing Thresholds > Display thresholds.

Change the value of the thresholds by choosing Change threshold (1 or 2)

HR graph with thresholds.

When computing statistics, the settings of the thresholds will provide an estimated value of
the percentage of time the signal was above threshold-1 and below threshold-2.
Overlapping channels
Show multiple signals within one Y-axis by choosing overlapping channels.

This will open the Select channel screen.
Select (highlight) a channel in order to add it to display it. To delete a channel from the
display, just click it again in order to deselect it.
Click OK to select the channels.
Use this option only to combine channels that are in the same y-range. This option is only available for
the line graphs display type.
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EEG signal (re)montaging
This feature is only available for NeXus-32.

The amplifier acquires EEG signals with a common average reference. From this common
average source signal, all other montages are derived. Montages can be changed on the fly,
also during a recording.
Change the montage by choosing EEG in the top menu. The current montage is indicated
with a check mark. The following EEG montages can be set:

Editing montages
Choose User Defined Montages > Open Montage Editor in the top menu to define own
bipolar or referential montage.
This will open the Montage Editor screen.

Enable bi-polar montage configuration by selecting Use Bi-Polar montage. Select EEG Source
Input 1 and EEG Source Input 2.
Enable configuration of uni-polar montages by selecting Use Referential Montage. Select
one or two reference inputs
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Select Save montage as… to save the current configuration. After restart of BioTrace+ the
new montage will appear in the drop down menu.

Delete the currently selected montage file by clicking Delete.

Adding or deleting channels
More channels (signals) can be viewed by right-clicking the screen and choosing Select
channels for overview.

The Select channels screen will appear.

Select (highlight) a channel in order to add it to display it. To delete a channel from the
display, just click it again in order to deselect it. Click OK to view the selection. At the bottom
the number of channels selected is shown.
Automatic channel selection
The option automatic channel selection will automatically show all signals that are also
shown in the feedback screen mode.
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Exporting session data
To export session data, choose File > Export session data.

The Export of Session Data screen will appear.

The following properties can be set:
- Time settings
 Time start
 Time end
 Export selections, segments, all data
 Exclude artifact segments
- Output options
 Type of data
 Output (sample) rate
 Output format (Tab or comma delimited ASCII, EDF, EDF+, Matlab)
 Repeat data in slower channels
- Additional options
 Include time as hh:mm:ss or as sample intervals
 Include event markers
 Include segments
 Separate file per segment
- Select data channels
Note that in case of EDF or EDF+ , the option Use maximum range will become available.
This function is necessary to accurately display EDF files in 3rd party software.
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Exporting (Q)EEG data
This feature is only available for NeXus-32

Select EEG the top menu to export all data. Alternatively select a segment and select Export
QEEG.
Choose the format:
- Eureka/Loreta
- Skil/Lexicor
- NeuroGuide
- EDF/EDF+ (supported by WinEEG)
- Skil 3.0 ASCII

Confirm the parameters in the following dialog box and click the OK button to save the file.

Click OK for exporting data. Click Save to save the file (by default in the folder
.../BioTrace/Export)
Exporting a selection
Alternatively, select data in the session overview screen, and choose Export selected data
from the drop down menu.
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5. Analysis & Reporting
This chapter describes analysis of session data. Data can be analyzed in the Session Overview
screen by clicking the following button in the Session Control Bar.

Session statistics
Right click the Session Overview screen and choose Compute statistics: > On entire session.

The Session Statistics screen will appear.

This will compute basic statistics (min, max, mean, etc.) for each signal that is displayed.
Text from this dialog box can be copied and pasted in to other programs
Computing statistics on segments
Right-click the screen and choose the option Compute statistics > On all segments.

The session statistics box will show up, showing basic statistics for each type of segment.
Computing statistics on a selected area
Select an area and click Segment: compute statistics.

Use this option to compute basic statistics for a selected area.
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Printing the statistics
Click the Print! (preview) button.

A preview of the graphs, basic client information and the statistics will be presented. This
preview can be printed or stored as a PDF file, depending on the software installed on the
computer

Intra-session trends
Right-click the Session Overview screen and choose Intra-session trend.

The Trend Report screen will appear.

Intra-session reports can be generated which are based on the segments. At least 2
segments must be defined. Choose the type of statistics.
Choose the type of output:
1. Copy/paste the report
2. Create an ASCII file.
Click OK to generate the report.
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Trend reports
Open the Client and Session Database and select a client. Click the Trend reports button.

The Select a Trend Report screen will appear.

Click View selected report for viewing previously generated reports. Click Delete report for
deleting reports.
Select Create new report! to create a new trend report.
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The Generate a New Trend Report screen will appear.

The following items can be configured:
- Number of sessions (min. 2 - max. 250)
- Number of channels. (up to 4)
- Statistics
- Type of DATA the trend report should use (total session, segments, exclusion of
data)
Choose Generate Report! >> to generate the report.
The Trend Report Generator will appear. When selecting Use entire session to generate
trend the report will immediately be generated.
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When selecting Use a specific segment type to generate trend the following box will
appear:

Choose the segment to generate the trend report for and click next. Now choose the way
the data should be presented and the Y-scale range.

After clicking OK a print preview will appear. Click the Print... button on the left top to print
the trend report.

The Close button will close the report.

HRV Analysis
For more information about the HRV analysis, please refer to the HRV white paper. Visit our
website (http://www.mindmedia.info/support/technical-whitepapers) for an overview of
the latest white papers.
Perform an HRV analysis by selecting a segment of data, or by right-click the session
overview screen and choosing Analysis Functions > HRV Analysis.

This will open the HRV Analysis & Interbeat Interval Table screen. In this screen it is possible
to set artifact criteria or remove artifacts. It is also possible to generate a HRV report or
export an IBI Table.
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HRV Resonance Frequency Analysis
Right-click the overview screen and choosing Analysis functions: > HRV Resonance Freq.

This will open the Select Segment Type screen.

Select the segment types to be analyzed.
Click OK to continue.
This will open the LF-Resonant Frequency and Pacer Settings screen.
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Select Set Pacer, to save the calculated data as the current pacer. Save a pacer for a client
by selecting Set Pacer & Save for Client. Whenever choosing this client, the pacer will
automatically be set to a specific pacer setting.
Click Print RF Report, to create a report of the RF calculation. The report will show the peak
frequency and if applicable, the segment withholding the peak frequency.

BVP Vascular Analysis
Right click in the overview screen and choose Analysis functions: > BVP Vascular Analysis.

This will open the BVP Vascular Flexibility Analysis screen.

The BVP vascular analysis is based on a small database and should be used as a relative
measure for improving vascular flexibility (decreasing vascular age).
This function uses BVP data to get an idea of vascular flexibility. Set the marker T1 at the first
peak and T2 at the second peak of the mean BVP signal.

Correlation Analysis
Right-click the session overview screen and choose Analysis functions: > Correlation Analysis
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The Correlation Analysis screen will appear.

To obtain the estimate of correlation, click the Apply button. Correlation is expressed in a
number between -1 and 1.
This function uses a Pearson Product Moment on epoch based channel data. Epochs contain
summary data and statistics, which are stored 4 times per second. Therefore the correlation
function works well on analyzing slow signals (<10 Hz) or trends over longer time periods
(larger than 10 seconds).

ERP/VEP
For more information, please refer to the ERP/VEP white-paper. Visit our website
(http://www.mindmedia.info/support/technical-whitepapers) for an overview of the latest
white papers.
For analyzing ERP/EP data it is required to build or load an *.presentation file.
Select ERP/VEP > Load Presentation in the top menu for loading presentation. Select a
*.presentation file and click 'OK'.
Select ERP/VEP > Build new Presentation in the top menu for building a new presentation.
Choose for an ERP, VEP, or ATT presentation. Set the type of paradigm and stimulus related
to the type of presentation. This can be set in the "ERP/EP Stimulus and Event Presentation
builder" screen.
Click Next >> for the ERP Event Presentation List Generator. In this dialog box it is possible to
set the parameters of the selected ERP paradigm.
Click Next >> to finish the presentation. This will open an alert box which will ask to build the
presentation.
Click 'OK'.
This will open the Event Presentation Editor for editing the events in the presentation.
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For performing the analysis, select ERP/VEP > ERP/EP Averaged Response in the top menu
(or right-click the session overview screen and click Analysis functions: > ERP/EP Averaged
Response)

This will open the ERP Analysis screen for editing the settings of the analysis.
Click Print ERP Report! for generating the report.
Click Save ERP: ASCII File for saving the ERP analysis.

SCP Averaged Response
For more information, please refer to the SCP white-paper. Visit our website
(http://www.mindmedia.info/support/technical-whitepapers) for an overview of the latest
white papers.
This function computes an ‘averaged response’ of SCP trials. Go to the top menu and choose
SCP/Trials > Build new trial sequence for building a new trial.
Click-right in the session overview screen and select Analysis functions: > SCP averaged
response.

This will open the Averaged Response Analysis screen.

The following items can be configured:
- The CHANNEL (signal) to average
- Definition of EPOCHS: how are epochs/events defined.
- Type of 1st/2nd/3rd segment, if applicable.
- Size of the Epoch (milliseconds).
- Average plain data or spectral of data
Averaged graphs can be smoothed by choosing Smooth averaged graph. Check Use Inversed
Polarity to inverse polarity.
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FFT Analysis
The FFT Analysis can be changed through Configuration > FFT Analysis Settings in the top
menu.
The Select channels screen will appear.
Select EEG channels for the FFT analysis and click OK.
The Fast Fourier (FFT) Analysis Parameters screen will appear.

Enable artifact rejection by checking Use Artifact Rejection. Click OK to finish the
configuration.
To perform a FFT analysis, select an area in the overview screen and click Analysis functions:
> FFT Analysis (EEG).

This function will offer the possibility to create offline spectra of 2 EEG channels.

NeuroMapping Report
This feature is only available for NeXus-32.

To create a NeuroMapping report, select an area in the overview screen and click
Neuromapping Report > Selected Segment
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The NeuroMap Analysis on selected Segment screen will appear
The left bottom graph will show the FFT for all EEG channels, the right bottom graphs show
the average.
Click Print Neuromap Report to sent the results to a printer. Click Export Results to ASCII to
output the results to a file.

EEG Signal Amplitude Mapping
This feature is only available for NeXus-32 and will only work in the EEG multiline graph, not in review
mode. It will also only work when a referential montage has been selected

In the EEG multiline graph screen, left click on the time-scale and drag the mouse.

The EEG Signal Amplitude Mapper screen will appear.
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Define a start sample location and an end sample location, by dragging the selection line to a
time point and pressing respectively the Set START and Set END button. Then select the
button Animate from Start to End.
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6. Objects
There are the following categories of objects:
General objects
These objects can be used for general purposes on a screen, they do not display any signals.
Icon

Object type
The Text Object

Description
Display (descriptive) text

The Image Object

Display a (static) image

Action objects
These objects can be used for performing actions on a screen.
Icon

Object type
The Button Control Object

Description
Display buttons which can perform
specific actions

Line graphs
These objects can be used for displaying signals in a line graph.
Icon

Object type
The Single Y-Scale Line Graph

Description
Display a line graph for 1 type of signal

The Dual Y-Scale Line Graph

Display a line graph for 2 types of signals

The Polylinegraph

Display up to 32 channels as linegraph
on 1 X-axis

FFT line graphs
These objects can be used for displaying signals in a FFT graph.
Icon

Object type
The Single FFT Spectrum
The Dual FFT Spectrum
The 3D FFT Spectrum
The Spectogram
The NeuroMap (NeXus-32 only)
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Description
Displays spectral analysis for a single
channel
Displays spectral analysis for a dual
channel.
Displays spectral analysis in 3D for a
single channel
Displays spectral analysis in 2D for a
single channel
Maps activity of the 21 remontaged EEG
channels on a 2D surface
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Bar graphs
These objects can be used for displaying signals in a bar graph.
Icon

Object type
The Bargraph

Description
Displays a bargraph for a single channel

The Vernier Instrument

Displays a horizontal bargraph for a
single channel
Displays a rectangle, circle, or image
which expands or contracts in all
direction for a single channel

The Zoomer Instrument

Numerical objects
These objects can be used for displaying numerical data.
Icon

Object type
The Numerical Instrument

Description
Displays numerical data

Imaging objects
These objects can be used for visualizing ranges of signals or display certain states.
Icon

Object type
The Animation Instrument

Description
Displays an animated series of images

The Water Effect Instrument

Displays a water ripple effect

The Direct-X Plug-In Instrument

Displays installed Direct-X plug-ins

The Clock Counter Instrument

Displays very small increments or
decrements of physiological signals

Multimedia objects
The following Multimedia objects can display certain states.
Icon
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Object type
The Video Object

Description
Plays video files

The Disc Object

Plays DVDs

The Game Object

Starts games

The Flash Animation Object

Plays an animation or video
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Capturing objects
These objects can be used for capturing audio and video.
Icon

Object type
The Video Capture Instrument
The Audio Capture Object

Description
Captures video and audio from a digital
camera or webcam
Captures only audio

The Text Object
Place a new object by selecting the following item in the Object Toolbar.

This object can display text.

When placing the text object on the grid, you can enter text. Otherwise right-click this object
and select Enter Text to enter or edit text.

This will open the Text Entry and Settings screen.

The following text options can be set:
- The Text alignment of the text defines how the text lines will be displayed.
- The Inset defines how much space there is around the edges of the text.
- The Multiline text contents with a maximum of 2500 characters.
- The Use Fade-in effect will initially display and then slowly fade in the text with
another color (Set in Font Settings).
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Select the following types of text can be selected:

Right-click the object and click Select Image to select a background image for the text box.
For other basic editing options, please refer to chapter 6. Editing.

The Image Object
Place a new object by selecting the following item in the Object Toolbar.

This object displays a static image that can be used for instruction, as information or as a
background image. Image objects support JPG and PNG images.

Right-click the image object and select Select Image.
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This will show the image selection dialog box.

Select an item from the list (left). The following options can be set:
- Alignment: this defines how the image will be placed or stretched inside the image
object box. Alignment options are displayed in the red box.
- Inset: This defines how much space there will be around the image.
For other basic editing options, please refer to chapter 6. Editing.

The Button Control Object
Place a new object by selecting the following item in the Object Toolbar.

This object displays buttons which can be used for performing specific actions. Button
objects support JPG and PNG images.
Enter text
Right-click a button and select Enter Text for editing text.

Change button image
Click Button Image to select an image for the button.
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This will show the image selection dialog box.

Alignment of the image object can be selected.
Display help text
This option will link a text object to the button. This text object should display the "help"
text, when the cursor moves over the button.
Right-click a button and select Enter Help Text to edit help text.

This will open the Text entry and settings screen.

Click OK for changing text contents.
Now right-click the text box which will be used to show the help texts and select Enter Text.
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Select Show HELP texts in this object from the drop-down menu at the bottom of the dialog
box.

Click OK. Now help texts will appear when hovering over buttons. Check Use Fade-in effect
for a fade-in effect.
Only 1 help text object can be displayed on a screen

Hyperlink to screen
A button can be used to hyperlink to another screen. A hyperlink will load a selected screen.
Right-click a button and select Hyperlink to screen.

An alert box will appear.

Click OK.
This will open the Screens folder in a file selector. Browse to a category and select a .*screen
file.
Click Open to link the screen.
Button actions
Apart from the basic hyperlink action, it is possible to set other button actions. Right-click
the button and choose Button Action.
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This will show the Button Action Settings screen.

There are three options for activating an action:

1. Manual click by user: no conditions have to be met.
2. Manual click after conditions are met: after meeting the conditions it is possible to
click.
3. Auto-click after conditions and timer/counter: No button is required to "click". The
action is performed automatically by a timer/counter and by meeting conditions.
Timer/Counter conditions are:
1) The screen has been displayed for a certain time (N seconds).
2) The session has run for a certain time. ( N seconds).
3) The trial counter has reached a certain level: The trial counter can be incremented
by this or other buttons. It starts at 0 at the beginning of a new session.
4) Game score has reached N points.
Combine up to 2 Boolean criteria with a logical AND or OR function. Select N/A for no extra
conditions.
Channel values are the statistical means for 15 seconds.
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When a button is clicked (or auto-clicked by a criterion) you can define a number of clickactions:
1) Generate an event marker
2) Create a new segment
3) Increment the trial counter by 1
The segment will cover the period from the ‘click time’ of the button, to the moment that a new
segment is created.

Select up to 4 button actions. Not all combinations will be valid though. There are several
button actions which can be defined.

Some actions need to link a file. Click the buttons in the following box to link a file:

Push object settings
Action Buttons can be used to push predefined settings to an object present on a screen.
The following settings of an object can be modified by a push action:
- Channel selection
- Display options and Ranges
- Feedback settings
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-

o feedback properties
o enable/disable feedback
o threshold settings
Visual object settings
o color and border
o title text

Select the Push screenobject setting in the list box:

Select Edit push screenobject settings below the list box.

Click Select to select the instrument on which the setting should be pushed.

Select the properties which should be pushed the selected instrument by ticking the
checkbox.
To setup the push settings, click on the button on the right of the selected push setting to open the
dialog showing all the options.
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Batch button settings
A batch button action can be used to apply more than 4 actions with a single button
(limitation of normal button action). It is also possible to use similar button actions multiple
times with the click of a single button.
Select the Batch Button Actions setting in the list box. Make sure this is the only selected
action.

Select Edit Batch Button Actions below the list box.

Button actions can be added or edited in the Batch Button dialog. Click Add or Edit to open
the Batch Button Editor.

The Description and Selected action can be set with Select action and Configure / Settings.
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Create a custom frequency range button
Select the Edit channel parameter setting in the list box.

Click the button Select the channel for editing to open the Select channel dialog.

Select a custom channel in this dialog and click Edit to open the Edit channel dialog of this
custom channel.

For information about editing channels, please refer to chapter 8. Inputs & Channels
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The Single Y-Scale Line graph
Place a new object by selecting the following item in the Object Toolbar.

The Single Y-Scale Line Graph can show one type of signal and is capable of displaying up to
4 channels of the same unit simultaneously.
Use the Dual Y-Scale Line graph instrument for displaying signals with different units and ranges (e.g.
heart rate and temperature).

Right-click the line graph object and select Display Options & Ranges.

Edit properties like:
- Range adjustments:
 Manual adjustment

-

-

-

-

 Auto fit to min-max (Enable or disable Linegraph: refresh each sweep)
 Auto fit to 0-max (Enable or disable Linegraph: refresh each sweep)
 Auto-center
Smoothing: 0 (Off) to factor 64.

Data type/stats:
 Current actual data value
 Successful POS/NEG feedback trails
 Successful POS/NEG transfer trails
 Successful VEOG POS/NEG trails
 All POS/NEG feedback trails
 All POS/NEG transfer trails
 All VEOG POS/NEG trails
Instrument style: thickness of the line
 Width 1 (thin)
 Width 2
 Width 3 (thick)
 Filled
Display options 1: polarity
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-

-

 Normal
 Inversed
Display options 2: grid options
 Show grid fine
 Show grid medium
 Hide grid
Event markers: show markers in Linegraph (offline)

The range of a line graph can also be adjusted with buttons in the graph. Click + or - to
increase or decrease the range of the Y-axis.

Click F to fit the range the Y-scale with minimum and maximum measurement of the session.

Change the range of the X-axis by clicking T for increasing the range and t for decreasing the
range.

For Color Settings, Backgrounds & Borders, Title Text(s), and Font Settings, please refer to chapter 6.
Editing.
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The Dual Y-Scale Line graph
Place a new object by selecting the following item in the Object Toolbar.

The Dual Y-Scale Line Graph is a multi-purpose instrument capable of displaying up to 2
types of signals simultaneously. The dual y-scale makes it possible to display two different
modalities in the same line graph.

Settings are similar to the Single Y-scale Line Graph.

The Polylinegraph
Place a new object by selecting the following item in the Object Toolbar.

The Polylinegraph can only show signals. No feedback can be set. A maximum of 32 signals
can be displayed on a single X-scale . The object auto-scales the signals, so the signal will
always fit.

Select a range of up to 32 data channels. Right-click the object and select Connect to data
channel.
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The Select channels screen will appear.

It is not needed to select all channels. Just select the first and the last channel in the range which need
to be displayed.

Click OK to select the range of channels.
Right-click an object and select Display Options & Ranges.

The following options can be set:
- Instrument style:
 Display Linegraphs only
 Display Linegraphs and FFTs
- Display options 1:
 Use Primary Color
 Use Channel Colors
- Display options 2:
 Show Grid Fine
 Show Grid Medium
 Hide Grid
 EEG Style grid
Other settings are similar to The Single FFT Spectrum.
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EEG Polarity
This feature is only available for NeXus-32.

The current polarity and range of the EEG displayed is shown in the left upper corner of the
EEG graph.

The above picture shows the NEGATIVE polarity is UP and the total range of the EEG signals
is 10 µV pk-pk.
Edit the polarity by right clicking on the graph and choose Display Options & Ranges.

Define the Grid and Polarity options under the Display Options 2 list box.

The EEG-Style grid will display negative signals UP. All other grid styles will display positive as
UP.

The Single FFT Spectrum
Place a new object by selecting the following item in the Object Toolbar.

This instrument computes and displays a spectral analysis of any time sampled signal. It is
based on the fast Fourier transform (FFT).

FFT Histogram (banded)
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Right-click an object and select Display Options & Ranges.

The following options can be set:
- FFT frequency range: Enter the start and end (Hz) of the frequency range.

-

FFT Epoch size: 1 to 8 sec.

-

Show FFT Statistics: enable showing mean, median, dominant.

-

Instrument Style: choose between polyline or histogram.
 Polyline: no fill, filled, gradient
 Histogram: normal, banded, gradient
Display Options 1:
 The 2D style is default option
 Show SCP Trial progress
Display Options 2:
 Show magnitude-spectrum (contains the square-root values of the power
spectrum)
 Show power-spectrum.
 Show a HRV spectrum

-

Other settings are similar to the Single Y-scale Line Graph.

For Color Settings, Backgrounds & Borders, Title Text(s), and Font Settings, please refer to chapter 6.
Editing.
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The Dual FFT Spectrum
Place a new object by selecting the following item in the Object Toolbar.

This object is very similar to the Single FFT Spectrum, except for the fact that it can display
the spectrum of two channels of data. The display of the spectrum is shown in a horizontal
fashion, where the first channel is shown to the left and the second channel is shown to the
right.

Right-click an Dual FFT Spectrum object and select Display Options & Ranges.

The following options can be set:
- Display options 1: Enable or disable refresh background.
- Display options 2:
 Show magnitude-spectrum (square-root values of the power spectrum)
 Show power-spectrum.
Other settings are similar to The Single FFT Spectrum.

The 3D FFT Spectrum
Place a new object by selecting the following item in the Object Toolbar.

This object is sometimes called a spectral ‘Waterfall’ or ‘Compressed Spectral Array’. The 3D
FFT Spectrum is a spectral analysis over time, where there are three axes:
1) The Y-axis, showing the amplitude of the signal
2) The X-axis, showing the frequencies
3) The Z-axis, showing the progress of time
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Right-click an object and select Display Options & Ranges.

The following options can be set:
- Instrument style: PolyGon no fill, filled, gradient
- Display options 1: 3D style
 1/16 sec refresh time
 1/8 sec refresh time
 1/4 sec refresh time
 1/2 sec refresh time
 1 sec refresh time
Other settings are similar to The Single FFT Spectrum. Show FFT statistics and Smoothing are not
supported.

The Spectrogram
Place a new object by selecting the following item in the Object Toolbar.

The main use for the Spectrogram is to provide a visual overview of spectral activity over
time. It displays a spectral analysis of a channel in a different way than a regular FFT
Spectrum:
- The Y-axis, showing the frequencies.
- The X-axis, showing the time.
- The magnitude of the activity is shown by the intensity of a color.
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Blue or dark colors indicate low level activity. Red, yellow and white colors indicate medium
and higher levels.
Low

Medium

High

Right-click an object and select Display Options & Ranges.

The FFT Epoch size is similar to The Single FFT Spectrum. Other options are not supported.

The NeuroMap
This object is only available for NeXus-32.

Place a new object by selecting the following item in the Object Toolbar.

This object maps the activity of the 21 remontaged EEG channels on a 2D surface, also called
a topographical EEG map or “Brain Map”.

The electrical EEG activity is analyzed through a FFT (fast fourier transformation). The
following measures are derived: of:
1.
2.
3.
4.
5.
6.

Amplitude (microvolt pk-pk)
Power (microvolt pk-pk squared)
Percent amplitude
Percent Power
Mean, Dominant and Median Frequency
Algebraic summation, substraction and ratios of the above

The selected parameter is plotted on 21 points interpolated over the entire map. Each white
dot in the image represents a 10-20 location.
Right-click the NeuroMap object and select Display Options & Ranges.
The following options can be set:
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-

Instrument style:



-

1: Dark blue-Red-Yellow: displays from cold color (low amplitude) to hot
colors (high amplitude).
2: Blue-Green-Red: displays from negative to positive.

Display options 1:




2D NeuroMap
3D NeuroMap

Other settings are similar to The Single FFT Spectrum.

Please note that a NeuroMapping display is always a limited representation of the electrical activity
which is going on in the brain. Both the spectral analysis on which it is based, as well as the graphic
display and interpolations can only provide an approximate image of the complex electrical activity of
the brain.

NeuroMap settings
Configure the NeuroMap settings by right clicking on the NeuroMap object and select
Choose NeuroMap Settings.
Another way to access these settings is by choosing the top menu EEG > NeuroMap
Configuration.
The Select a NeuroMapping Settings screen will appear, connect to one of the parameters.
To edit these settings, click on Edit. Another way to access these settings is by right clicking
on the NeuroMap object and select Edit Neuromap Settings.
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The NeuroMap Channel Editor screen will appear.

The following can be set:
- NeuroMap Channel name: change the name of the channel
- Type of computation: select one of the computations
- Frequency range: Insert the range of activity for being mapped
Right below the measuring unit of the color representation is shown (in this case µV pk-pk).

Beware to adapt the range of the instrument to the selected type of computation.
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The Bargraph
Place a new object by selecting the following item in the Object Toolbar.

The Bargraph is a multi-purpose object capable of displaying 1 channel.

Right-click an object and select Display Options & Ranges.

The Display Options & Range Settings screen will appear. The following options can be
edited:
Edit properties like:
- Range adjustments:
 Manual adjustment
 Auto fit to min-max (Enable or disable Linegraph: refresh each sweep)
 Auto fit to 0-max (Enable or disable Linegraph: refresh each sweep)
 Auto-center
- Smoothing: 0 (Off) to factor 64 smoothing of the signal.
- Data Type/Stats:
 Show the "min, max, mean, standard deviation, coefficient of variability and
RMS amplitude" for the past 15 seconds or the whole session
 Show all basic statistics for the past 15 seconds or the whole session.
 Show the current state of the reward counter (1-8).
 Show the absolute (ABS) value.
 Show the % above or below threshold 1 (60 sec.)
 Show the current game score or level.
 Show screen second count-down and count-up
 Show pace settings (beats per minute)
 Show trial data type/statistics like trial time, trials completed, positive
success.
 Show previous segment mean.
- Instrument style: type of bar graph (see images above)
 Classical bargraph
 3D bargraph
 Zero in the middle bargraph
- Display options 1: polarity
 Normal
 Inversed
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-

Display options 2: bar options
 Rectangle
 Image (select image for vertical movement)

The range of a bargraph can also be adjusted with buttons in the graph. Click + or - to
increase or decrease the range of the Y-axis.

Click F to fit the range the Y-scale with minimum and maximum measurement of the session.

It is possible to link a bar graph to another object. Right-click a bar graph and select Link to
instrument.

This will open the Link to input from another instrument screen.

Check This is a secondary screen if the object is placed on a secondary screen. The object
will be linked to an object on a primary screen. It will automatically link the threshold state.
For Color Settings, Backgrounds & Borders, Title Text(s), and Font Settings, please refer to chapter 6.
Editing.
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The Vernier Instrument
Place a new object by selecting the following item in the Object Toolbar.

This instrument is rather similar to the Bargraph, except that it displays signals horizontally.

Right-click an object and select Display Options & Ranges.

It is possible to use a counter as display option 1.
Other settings are similar to The Bargraph.

The Zoomer Instrument
Place a new object by selecting the following item in the Object Toolbar.

The graph of the Zoomer Instrument displays an rectangle, circle, or image which expands or
contracts in all directions.

Right-click an object and select Display Options & Ranges.
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Edit properties like:
- Instrument style: type of zoomer (see images above)
 Rectangle zoomer
 Circle zoomer
 Image zoomer
- Display options 1: polarity
 Normal
 Inversed
Other settings are similar to The Bargraph.

The Numerical Instrument
Place a new object by selecting the following item in the Object Toolbar.

This object displays only numerical data.

Right-click an numerical object and select Display Options & Ranges.

The following options can be set:
- Data Type/Stats:
 Show the "min, max, mean, standard deviation, coefficient of variability and
RMS amplitude" for the past 15 seconds or the whole session
 Show all basic statistics for the past 15 seconds or the whole session.
 Show the current state of the reward counter (1-8).
 Show the absolute (ABS) value.
 Show the % above or below threshold 1 (60 sec.)
 Show the current game score or level.
 Show screen second count-down and count-up
 Show pace settings (beats per minute)
 Show trial data type/statistics like trial time, trials completed, positive
success.
 Show previous segment mean.
- Instrument style: set 2 to 4 digits after decimal
- Display options 1: Use counter #1 - #8 (if needed)
- Display options 2:
 Show value
 Input value
6. Objects

101

Link to instrument
It is possible to link a numerical object to another object. Right-click a numerical instrument
and select Link to instrument.

Open the Display Options & Ranges for selecting the instrument style:

Check This is a secondary screen if the object is placed on a secondary screen. The object
will be linked to an object on a primary screen. It will automatically link the threshold state.
For Color Settings, Backgrounds & Borders, Title Text(s), and Font Settings, please refer to chapter 6.
Editing.

Input value
The Input value is a special numerical object.

Enter a value manually by using the numerical buttons on the keyboard and clicking the Set
button. Click + or - to increase or decrease the range of the value.
Select Input value > via keyboard in the Display options and range settings to enable input
values.

Choose between the following value options:
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The Animation Instrument
Place a new object by selecting the following item in the Object Toolbar.

The Animation Instrument uses an ‘animated’ series of images that start in one position and
end in another. These images are played in a sequence which usually show a change, move
or expand.

Right-click the image and select Select Animation

Select an item from the list and set alignment and inset.
It is possible to add your own animations (*.bmp or *.jpg files). Animations are stored in the folder
...\BioTrace\Animations\<name of animation>. The first file of an animation is always named
<filename>0001.jpg, the second <filename>0002.jpg, etc.

Right-click an animation object and select Display Options & Ranges.

Options which can be set are:
- Range adjustments: Manual or auto adjustment of the Y-scale range.
- Smoothing: 0 (Off) to factor 64 smoothing of the signal.
- Instrument style: Play or cycle (loop)
 Play one way (> or < threshold)
 Play both ways
 Cycle one way (> or < threshold)
 Cycle both ways
- Display options 1: Direction of the sequence.
 Normal
 Inversed
- Display options 2: Speed of animation (frames/sec.)

6. Objects

103

Visualize range
It is possible to link an animation object to the range of another object. Right-click the
animation and select Link to instrument.

This will open the Link to input from another instrument screen.

Select Link to range based state for linking the animation to a range of another object.
Check This is a secondary screen if the object is placed on a secondary screen. The object
will be linked to an object on a primary screen.
For Backgrounds & Borders and Title Text(s), please refer to chapter 6. Editing.

Visualize state
It is possible to link an animation object to the threshold state of another object. Right-click
the animation and select Link to instrument.

6. Objects

104

This will open the Link to input from another instrument screen.

Select Link to threshold state for linking the animation to a threshold of another object.
Check This is a secondary screen if the object is placed on a secondary screen. The object
will be linked to an object on a primary screen.
For Backgrounds & Borders and Title Text(s), please refer to chapter 6. Editing.

The Water Effect Instrument
Place a new object by selecting the following item in the Object Toolbar.

This object shows a water ripple effect where the height of the ripples reflect the magnitude
of the linked object.

The maximum ripple level is at the top of the range. Right-click an object and select Select
Image.

This will show the image selection dialog box. Select an item from the list and click OK.
6. Objects

105

Press the R key to refresh the screen for displaying the new image.

Right-click an object and select Display Options & Ranges.

The following options can be set:
- Display options 2: Speed
 Slow
 Normal
 Fast
Other settings are similar to The Animation Object.

The DirectX Plug-in Instrument
Place a new object by selecting the following item in the Object Toolbar.

All kinds of DirectX plug-ins can be installed. The DirectX Plug-in object can process a set of parameters
for each object it is linked to.
The following parameters are available to the Plug-in object:
Channel name
Data value
Range (linked instrument)
Threshold level
Threshold state (above/below)
Reward tag (above/below)
Inhibit
A Plugin object may use all available parameters or a selection thereof.

The Mandala Plug-In is a default DirectX plug-in. It rotates colored Mandalas in a 3D space.
The Mandalas are layered on top of each other and their size, brightness and rotation can be
steered.
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Press the 'E' key and right-click on one of the black handles of the object.

Click Select PLUGIN type for selecting a plug-in. Click PLUGIN settings for setting the plug-in
properties.

The Mandala Layer Properties screen will appear.

This settings screen is different for each DirectX plugin.

The Mandala uses image sets. Each set consists of 3 layers which are projected into 3D space
and are made to respond to the physiological activity. Add a set and click the << Add Set
button.

When selecting more than 1 set (max of 8), it is possible to switch sets in N seconds or N
feedback frames.
A set consist of two dynamic layers and one static layer. Edit properties like:
- Size
- Brightness
- Rotation speed (dynamic layers only)
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Select up to 3 objects that control both dynamic layers. Only linked objects can be selected.
Right-click the Mandala object (on a black handle in editing mode) and select Link to
instrument to link objects.

Multiple objects can be selected.

The Clock Counter Instrument
Place a new object by selecting the following item in the Object Toolbar.

This object can be used to feed-back very small increments or decrements of physiological
signals (e.g. for temperature).

The step size of the increment/decrement can be defined from very small (0.0001) to large
(1000) by clicking the + and - buttons in the middle.

It is not possible to edit Display Options & Ranges.

The Video Replay Object
Place a new object by selecting the following item in the Object Toolbar.

This object plays video files. It does not display physiological data. The video file is replayed
in a window and will play only when the session is running in record or replay mode.
A maximum of 4 video objects can be used on a single screen.
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Right-click a video and click Select video file.

This will show the Select video files screen.

Select a video file from the Available video files list. Click Play to preview the video. Click
Stop to stop the preview.
Click
(or by a double left mouse click) to add a video to the Selected video playlist.
Multiple videos can be selected. Check Randomize list box to shuffle the sequence of the
selected videos.
The video selection window allows you to play the video from a specific point in time. Drag
the slider to the desired point, and click OK.

It is possible add videos (*.avi, *.wmv, *.asf, *.divx). Videos need to be stored in the folder
...\BioTrace\Videos.
Click

to remove a video from the Selected video playlist.

Click Up or Down for moving the selected video file up or down in the playlist.
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Check Loop video file to replay a video once it ends.
Check Always play video if a video does not need to respond to feedback.
A video can pause, shrink or darken during inhibits. This can be set by right-clicking the edge
of a video and selecting or deselecting the following options:

The Disc Object
Place a new object by selecting the following item in the Object Toolbar.

The Disc Object plays video from a DVD-disk. The DVD file is played in a window and will play
only when the session is running in record or replay mode. Only one DVD object can be used
on a single screen.

Insert a DVD and wait until it is loaded. Go to Configuration > MultiMedia DVD Control in
the top menu (or press the M key).
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This will open the MultiMedia DVD navigation screen.

Use the time slider to move through the current video or return to the DVD menu by clicking
Go to DVD Menu. DVD navigation is only possible during recording or replay of a session.
Similar to the Video Replay object, the Disk object supports pausing and darkening of videos during
inhibits.

The Game Object
Place a new object by selecting the following item in the Object Toolbar.

This object allows for playing games controlled by other objects and/or the keyboard.

Right-click on one of the black handles of the object (in editing mode).

Select Select Game for selecting a game.
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This will open a file selector. Select a game, edit alignment and inset, and click OK.
Game settings
Select Game Settings for editing game settings.

The Game settings screen will appear.

There are two types of controls:
- The B: is a Boolean control, which is either true (> threshold) or false (< threshold).
The control can be connected to an instrument (object).
- The V: is a Variable control, defined by the level of the signal within the range of the
linked object.
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Link to object
It is possible to link a game object to another object. Right-click a bar graph and select Link
to instrument.

Check This is a secondary screen if the object is placed on a secondary screen. The object
will be linked to an object on a primary screen. It will automatically link the threshold state.
Link to data channel
It is also possible to link a game object to a data channel. Right-click a bar graph and select
Link to data channel.

This will open the Link data channels screen.

Select up to 10 data channels.
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The Flash Animation Object
Place a new object by selecting the following item in the Object Toolbar.

This object play an animation or video file in *.swf (Shockwave Flash) format. The flash file
will be played when a screen is opened.
Press the 'E' key and right-click on one of the black handles of the object.

Now select Select Flash file

This will open the SWF file selector. Add own *.swf files in the ..\BioTrace\SWF directory.
Select a file and click OK. It is also possible to adjust alignment and inset.
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The Video Capture Object
Place a new object by selecting the following item in the Object Toolbar.

The Video Capture Object captures video from a digital camera or webcam during a session.
The video will be synced with the data. Only one object can be used for video capture on the
primary or secondary screen. During the session the video capture object will show a
preview of the video.
Connect the camera before starting BioTrace+ and make sure to install the latest drivers.

Right-click the video capture object and select Capture Settings.

A dialog box will appear for configuring the video capture.

Edit the following settings:
- Select video device: Select a camera or webcam in the list. Make sure to attach the
video camera or webcam and install the latest driver. Best is to connect the device
before starting BioTrace+.
- Select quality: this property defines how ‘good’ the image quality will be. Higher
quality will generate larger files. This is only recommended for short sessions.
- Select audio device: Select an audio source.
- Mirror: Check 'Flip horizontal' for a mirrored view of the webcam.

6. Objects

115

The Audio Capture Object
Place a new object by selecting the following item in the Object Toolbar.

This object only captures audio. Typically it will use a microphone to store the sounds or
voice during a session.
Use the Video Capture Object for combining recording audio and video.

Right-click the audio object and select 'Capture Settings'

This will open the Audio capture settings dialog box.
Settings are similar to The Video Capture Object.
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7. Editing
This chapter describes editing possibilities of screens and objects.
Press Ctrl + Z to undo tasks which are performed in editing mode. This can be done for a maximum of
five previous tasks.

General screen properties
Except for menus, all screens can be edited. The following properties can be changed:
- Background colors
- Background sound
- Screen notes
Background colors
Right-click on a screen background and select Set Background Colors.

This will open the Background & Border Options screen.

Choose between the following background fill options:
- Non/ transparent (default background image)
- Solid color
- Gradient color
- Images
The solid color and gradient color options can be set with Color fill, Gradient color, and
Background color.
Images which can be used as a background, are stored in 'Textures' folder of the BioTrace+ directory.
New images can be added by placing them in this folder.

Check Colorscheme push to include the object in the color scheme.
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The Background push option allows a client screen’s object-colors to be in sync with the
corresponding therapist object-color.
The Border style and Drop shadow option are not applicable for the screen background.

Background sounds
Right-click the background of the screen and click Set Background Sound.

The Digital Sound & Song Feedback Settings dialog box will appear.

Select one of available media files for playing the sound when the screen is loaded (e.g. an
instruction). When the next screen is loaded, the background sound will stop. Check the
option Loop Song/Sound for replaying the file for as long as the screen is opened.
The available media files are stored in the 'Audio' folder of the BioTrace directory. New audio files can
be added by placing them in this folder.

For feedback options with audio, please refer to chapter 3. Feedback

Editing screen notes
Click the following button:

Or right-click the background of the screen and click Show Screen Notes
Text can be edited by selecting Edit.
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This will open the Text Entry and Settings screen.

Edit text in the text box. Press OK to save notes. Click the
key) to close the pop-up window.

button (or press the Escape

General object properties
All items on a screen are called objects, such as text boxes, images, feedback instruments,
videos, buttons etc. The following object properties can be changed:
- Background & borders
- Color settings
- Font settings
- Title text
Background & borders
The background of each object can be set by a right-click and select Background & Borders.

The Background & Border Options screen will appear.
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Choose between the following background fill options:
- Non/ transparent (default background image)
- Solid color
- Gradient color
- Images
The solid color and gradient color options can be set with Color fill, Gradient color, and
Background color.
The border style will create a 'rectangle border' around the instrument/object. Check
Enabled for the Drop shadow option to create a shadow below the object.
It is also possible to enable or disable color schemes.
Color settings
Change properties of the objects, instruments, scales, and screens by right clicking on them
and choose Color Settings.

The Instrument Color Options dialog box will appear.

The following color settings can be edited:
- Primary drawing color: The color that the object uses for drawing the signals.
- Use channel color: Use color in channel set.
- Secondary drawing color: The color that is used for the background.
- Gradient fill pattern: Some objects can also use a gradient for displaying signals.
- Auto color change: Automatic color change for above or below threshold
- Threshold based color change: Check Enabled for activating a color change that will
occur when the signal are above or below threshold. Select a color for above and
below threshold.
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-

Color of X and Y scale: The color of the scaling.
Color of scale grid: The color of the scaling grid.
Scale text color: The color of the scaling text.
Title text color: The color of the title text.

Some objects have limited settings possibilities.

Title text
A title text can be used to label an object. Enter or edit a title text by right-clicking the object
and choose Title Text(s).

The Instrument Title Text Settings box will appear.

Enter or edit text in the text field(s). Click Load default channel name(s) to fill in the title
texts using the channel names.
Enable or disable the following options:
- Use entered text as title
- Use channel name as title
- Show title inside object
Choose left, centered, or right text justification with Justify title text. Change the
characteristics of the font with Title font. A standard font selector box will appear.
The title text color can be set with the option Color Settings.
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Fonts
Right click and object and choose Font Settings to edit fonts.

This will open a standard font selector box.

In this box it is possible to select the font, style, size, effects, and color.
This will not change the title font.

Display options & ranges
Right-click an object and select Display Options & Ranges.

It is possible to change ranges of the Y-scale, configure FFT settings, set smoothing, or data
type/statistics of objects.
All object settings are explained in chapter 5. Objects

Displaying other data channels
All objects on a screen that display data must be connected to at least one data channel.
Press the right mouse button on an object and click Connect to data channel.
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The Select channels screen will appear.

Select one or multiple data channels. The channel list box will indicate the number of
selected channels at the bottom. Click the OK button for saving the selection.
How to edit data channels, please refer to chapter 8. Input & Channels

Linking objects
Some objects can be linked to another object. It will use the threshold state or data and
scale range of the object. Right-click an object and select Link to Instrument.

All objects are explained in chapter 6. Objects
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Object position and size
Enter the editing mode by selecting Screen > Edit Screen ('E') in the top menu.
The background will show a grey grid. All the objects on the screen will now have black
handles.
Moving objects
Click on the middle of an object, the cursor will change into a symbol with 4 arrows,
indicating it can be moved. The objects will snap to the grid, while moving the objects.

Objects can move freely when turning the grid off. This can be set in the top menu under
Screen > Grid > OFF (No Grid).
The default grid setting is 'fine', it can also be set to 'medium' or 'extra fine'.
Resizing objects
Click on a handle of an object, the cursor will change into a symbol with 2 arrows, indicating
it can be resized.

By 'dragging' (left clicking and holding) the handles of the object, it is possible to resize
objects.
Deleting objects
Delete an object by right clicking the object and select Delete (or select the object and press
the Delete key).
Copying objects
Right-click an object in the editing mode, and choose Copy (or select an object and press Ctrl
+ C). Right-click the object again and choose Paste (or press Ctrl + V) to paste the copy.
This will create a copy which has exact same size and properties as the original object.
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Placing new objects
For more information on objects, please refer to chapter 6. Objects

Enter the editing mode by selecting Screen > Edit Screen ('E') in the top menu.
The Object Toolbar will appear.

Select an object from the Object Toolbar by clicking it once. The object will now show an
orange line around it.

Place (or 'Drop') the object by left-clicking in the grid of the screen.

The Select channels screen will appear.

Select one or multiple data channels which have to be displayed. Click the OK button for
saving the selection.
A maximum of 64 objects can be placed in one screen. In case the object is capable of
displaying signals, it can be connected to one or more channels.
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Right-click an object in the Object Toolbar and select Explain this object... for more
information about the object.

For a comprehensive explanation of all different objects, please refer to chapter 5. Objects

Creating a new screen
Click File > Build New Screen in the top menu.

An alert box will appear. Click OK for entering edit mode.
A screen will appear in which a name for the new screen can be entered.

Enter a name and click OK. A screen will appear for selecting a screen category.

Select a screen category and click OK.
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Saving a screen
Overwrite existing screen
It is not recommend to overwrite default screens. In case you want to change a default screen, save
this screen as a new screen.

Save an existing screen by choosing File > Save Screen
An alert box will appear.
Click YES to overwrite an existing screen.
Save as new screen
In order to save a screen as a 'new' screen, choose File > Save Screen As. The Screen Browser
will appear. Select a category and click the Save Screen button.

The Save as a New Screen box will appear.

Enter a screen description of the screen and the designer's name. Click OK to save the
screen.

Deleting screens
Select a screen in the Screen Browser and click the Delete Screen button or just press the
Delete key. Click YES to confirm.

Backing up screens
Screens can easily be copied to a removable disk (or another medium). Open the folder
Screens in the BioTrace+ directory (e.g. ...\BioTrace\Screens).

Open the folder Protocols for backing up protocols.

Now open the screen category folder in which the screen has been stored. Select the
screen(s). A single screen always exists of two files, a *.screen and *.jpg. Select both files by
clicking a screen and holding the Ctrl key.
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Click the right mouse button and select Send to > Removable Disk.

This option will copy the files to a removable disk.
Restoring screens
Copy the *.screen and *.jpg file(s) which are stored on the removable disk. Paste the files
into a designated Screens folder of BioTrace+ on the hard disk (e.g. MyScreens)

The screens can now be opened in the Screen Browser in the category in which the files are
placed.

Defining a sequence of screens
It is possible to display the screens in a defined sequence, like a slide show. Click Screen >
Edit Sequence Script in the top menu.
This will open the Screen Sequence Editor.

The script editor can be used for defining a fixed sequence of screens. A button object can
start this script. These scripts can be used for building own protocols.
To create a new script, select a screen category. Add a screen to the script by clicking Add
New Screen to Sequence.

This will open the Trial Settings screen.
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Edit the following properties:
- Select screen: all screens of the previous selected screen category can be selected.
- Load into the: choose for a primary or secondary screen.
- Duration: how long will the screen displayed?
- Generate segment: select a segment type. Check None to end the current segment
and if no new segment is required.
- Text line: text can be used for an automatic marker or as an instruction (check these
options below)
- Pause mode: check this option when pause mode is needed. Un-pause the session
manually.
- Block reward counter: reward counters can be blocked for specific screens.
Save a script by clicking Save current Script as.... This will save a *.script file.

It is possible to load an existing script by clicking the Load a Script button.

Select a *.script file and click Open to open the script.
Click Edit to edit a trial screen.

Click Delete for deleting a screen in the sequence.

Select a screen and click Insert to insert a screen

Click Clear Script to delete trial screens.
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8. Inputs & Channels
This chapter describes the sensor input settings and channel settings. The first 4 (NeXus-4)
or 10 channels (NeXus-10) of a channel set are used to store the physiological data coming
from the sensors. The other channels are virtual data channels which have computed data,
derived from the sensors. You always need to connect a specific channel set to a screen. By
default this is the Default-channel set.

Sensor inputs
Default sensor input
The image below shows an example of the Sensor Input configuration for NeXus-10:

Press I to open the Sensor Input and Samplerate configuration. Input A, B, C, and, D can be
used for electrophysiological signals Input E, F, G and H the peripheral sensors can be
connected in any combination. Inputs I and J can be used for oximetry, the NeXus Trigger
Interface (%SpO2 or pulse) and the respiration pacer.
The Sensor Input and Samplerate configuration is saved as part of channel configurations and will
display the input-channels of the last loaded channel configuration. This can be the channel
configuration that is linked to the screen or a channel configuration that is manually loaded.
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The image below shows an example of the Sensor Input configuration for NeXus-4:

Check File > load channel set to take a look at the available channel configurations.
Input A, B can be used for electrophysiological signals on inputs C and D, 2 peripheral
sensors can be connected in any combination.
The image below shows an example of the Sensor Input configuration for NeXus-32:
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The first 24 inputs can be used for EEG signals in the frequency range from DC to 800Hz.
Inputs 25-28 can be used for electrophysiological signals. On inputs 29-32 peripheral sensors
can be connected in any combination. Inputs 33-34 can be used for oximetry, the NeXus
Trigger Interface (%SpO2 or pulse) and the respiration pacer.
Sessions recorded with BioTrace+ versions prior to V2015B contain a maximum of 3 auxiliary inputs of
the NeXus 32, instead of 4. Oximetry and pacer signals recorded with these previous versions will be
available on channels 33 and 34, instead of 32 and 33 as was the case during recording.

Changing sensor input
All signals are acquired by and derived from the sensors. Any change to a sensor
configuration will modify the way the physiological data is represented in all the screens.
Go to the top menu and select Configuration > Sensor Input Config. (or press the I key).
This will open the Sensor Input and Samplerate Configuration screen.
Use the dropdown menu to change the input.

Click OK to confirm the changes.
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Change EEG frequencies during sessions
Go to Configuration > Channel freq. control in the top menu (or press SHIFT + C).
This will open the Frequency Control Panel.

With this panel it is easy to change the individual frequency during a session.
Set start and end points, or shift a whole band in steps of 1Hz, 0.5 Hz, 0.25Hz or 0.1 Hz.

Choose between Shift band and Start and End frequency control mode.

Check Enable to only show the channels that are being used.
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Change EEG training input
This feature is only available in EEG screens for NeXus-32.

Open the EEG Training Input Selection by clicking the following button in the toolbar (or go
to EEG > EEG Training Input in the top menu or press X).

See section EEG signal (re)montaging on how to change the Signal based on <…> to another
montage.

Select the input (T1-T4) by using the dropdown box in the upper right corner.

Select the 10-20 location or other sensor input on the right selection box and click OK. The
training signals can be changed at any time. Save the channel configuration to save the
training signal settings for next usages.

Change sample rates
Go to the top menu and select Configuration > Sensor Input Config. (or press the I key).
This will open the Sensor Input and Samplerate Configuration screen.
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For changing sample rates, first check the selection box Unlock samplerates.

An alert box will appear.

Click OK for closing the alert box.
Use the dropdown menu for changing the sample rate of an input.

Click OK to save the changes.

Store data on flash memory
Go to the top menu and select Configuration > Sensor Input Config.
This will open the Sensor Input and Samplerate Configuration screen.
Click the Configure Flash Sessions button.
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Configuration for NeXus-10/ NeXus-32
The Configure Flash Session screen will appear.

Select the correct flash Card Drive. This drive will be detected automatically.
Select the sensors that need to be stored on the flash card.
Sample rates cannot be changed afterwards for stored data on a flash card.

Click the Configure button to save the configuration.

A dialog box will appear. Click OK to close this box. The configuration is now saved.
The Configure Flash Sessions screen will also show the available recording time that is left.
This will depend on the capacity of the flash card and the selected sensors (e.g. the four fast
inputs (A,B,C, and D) with a high sample rate need more storage space).
The physiological data will be stored in a compressed fashion. That is why it is needed to
import the session data files from the flash card, before they can be used.
If NeXus is used in ‘ambulatory mode’ the wireless data connection is switched off.
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Configuration for NeXus-4
The Configure Flash Memory screen will appear.

A new configuration requires deleting all current measurements and configuration details.

Click the Clear Memory button.
A dialog box will appear. Click Yes to proceed. It can take up to 5 minutes to erase the total
memory.

The Configure Flash Memory screen will also show the available recording time that is left on
the NeXus-4 memory. This will depend on the selected sensors (e.g. the four fast inputs
(A,B,C, and D) with a high sample rate need more storage space).

Click Configure to store the selected configuration to the NeXus-4 memory.
Two dialogs will appear. Click on Yes and then OK to complete the configuration.

8. Inputs & Channels

137

Load and attach a channel set
To load and attach a channel set to a screen, go to File > Load channel set in the top menu.
After selecting a *.channels file, a dialog box will appear.

Click Yes to attach the channel set to the current screen.

Click Yes to save the screen. This will load the channel set automatically next time.
It is not recommended to overwrite default screens!

A third alert box will appear.

Click Yes for saving the screen with the attached channel set.

Edit channels
It is not possible to change channel sets during recording!

To edit channels, go to Configuration > Channel set config. in the top menu (or press the C
key).
Or right-click an object and select Connect to data channel or edit data channel.
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This will open the Select channels screen.

The <Name> after Select channels: at the top of the screen, displays the name of the
currently loaded channel set (e.g. <Default.channels>).
Select a channel and click Edit.
This will open the Editing channel screen.
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The following properties can be edited for every channel:
- Channel name: Name of the channel
- Signal source 1 (and 2): select one of the defined channels from the dropdown.

For changing the signal source for the first 4 (NeXus-4) or first 10 (NeXus-10) channels, please refer to
chapter 12. Sensor input.

-

Notch filter: The notch filter can be changed in the channel set configuration. This
filter does not change the raw signal storage and can always be turned off to return
to the original data.
 Off: Notch filter will not be active (default).
 50 Hz notch on: The filter passes all frequencies, except for 50 Hz.
 60 Hz notch on: The filter passes all frequencies, except for 60 Hz.

-

Type of unit to display: The unit options depend on the type of signal and category of
data processing. Sometimes it is possible to choose between different types:
 µSiemens / KOhm: For skin conductance (GSR)
 °C / °F: For temperature
 B/Min. / MS: For HR (BVP)
 µV pk-pk / µV RMS: For root mean square amplitudes (EEG)
Default color: Select a color which is used for displaying the signal in session
overview.

-

Use the left and right arrows at the bottom of the box to navigate through the channels.

Click Apply to save changes without closing the dialog box. Click OK to save changes and to
close the dialog box.

Create and save channel sets
Most of the default screens are connected to a default channel set. If no channel set can be
found, the default channel set will always be loaded.
When making changes to a channel set (or creating a new one), select File > Save channel
SET as… in the top menu.
It is not recommended to overwrite default channel sets! Create a new channel set when making
changes and connect them to the screens.

Save the *.channels file in the "channels" folder of BioTrace+.
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Back up channel sets
Saved channel sets can easily be copied to a removable disk (or another medium). Open the
folder Channels in the BioTrace+ directory :

Select the *.channels file(s). Click the right mouse button and choose to copy the file(s) to a
removable disk:

Restore channel sets
Copy the *.channels file(s). Paste the file(s) into the Channels folder of BioTrace+ on the hard
disk:

Within BioTrace+, the channel sets can now be loaded.
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Data processing
When editing the type of data processing, basic knowledge of physiological signals and statistics is
required.

Go to Configuration > Channel set config. in the top menu (or press the C key).
Or right-click an object and select Connect to data channel.

This will open the Select channels screen.
Select a channel and click Edit to open the Editing channel screen.

The following types of data processing can be selected:
- Linear Algebra
- Coherence and Correlation functions
- Digital Filters
- General Signal Processing
- Frequency Analysis functions (FFT)
- Logging function
- Custom computation
Linear algebra functions
All linear algebra functions require two selected channels.

Only use channels with the same sample rate.
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The following types of computation can be selected:

It repeats this function for each value in the array of data values that a signal holds.
Add: source1 + source2
This function computes the sum of the signal values from source1 and source2.
Subtract: source1 - source2
This function computes the difference of the signal values from source1 and source2.
Multiply: source1 x source2
This function computes the product of the signal values from source1 and source2.
Divide: source1 / source2
This function computes the ratio of the signal values from source1 and source2.
Average: (source1 + source2) / 2
This function computes the mean of the signal values from source1 and source2.
Subtract (factor): source1 - (source2 x factor)
This function computes the difference of the signal values from source1 and source2 times a
factor X.
Enter the factor number in the Editing Channel screen.
Average SCP: (source1 + source2) / 2 - DC
This function computes the mean of the signal values from source1 and source2 with a DC
correction.
Coherence and correlation functions
All linear algebra functions require two selected channels.

Only use channels with the same sample rate.
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The following types of computation can be selected:

EEG coherence
Coherence is a measure of cross-correlation between two signals in the EEG frequency
domain.
EEG Coherence is computed by the ratio of the auto-spectra of the two channels and their
cross spectra.
The following parameters can be set:

-

The size of the FFT Epoch: 1, 2, 4, 8, 16, or 32 seconds. This depends on the sample
rate of the signal source.
The frequency range: Select at least a range of 4 Hertz when using 1 second Epochs,
or 2 Hz when using 2 second epochs.

Correlation
This function uses a Pearson product-moment to compute the linear correlation between
two signals.
The signals must have the same sample rate

Set the following parameters:

-

The size of the Epoch: The size in seconds of the samples that should be analyzed. If
the sample rate is for instance 32 SPS, setting a 16 seconds epoch means that 512
points of data will be analyzed.

Correlation may result in a value between -1 (negative linear correlation) and +1 (positive
correlation).
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Digital filters
The following types of computation can be selected:

FIR filters
FIR stands for Finite Impulse Response. There is no ‘feedback’ in the filter and after a certain
fixed time the filter will reset to zero when an impulse (a ‘1’) is run through it.
The following type of FIR filters can be distinguished:
- Band pass filter: Passes frequencies in a predefined band.
- Low pass filter: Filters out high frequencies, low frequencies are passed.
- High pass filter: Filters out low frequencies, high frequencies are passed.
- Band stop filter: Filters out only a (narrow) band of frequencies. The rest is passed.
Select the following subtype or parameter:

Select the order of the filter:

IIR filters
IIR stands for Infinite Impulse Response because there is ‘feedback’ in the filter and it takes a
long time for the filter to reset to zero when an impulse (a ‘1’) is run through it.
The following type of FIR filters can be divided:
- Band pass filter: Filters out the frequencies in a predefined band.
- Low pass filter: Filters out high frequencies, low frequencies are passed.
- High pass filter: Filters out low frequencies, high frequencies are passed.
- Band stop filter: Filters out only a (narrow) band of frequencies. The rest is passed.
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Select the following subtype or parameter:

Select the order of the filter:

Enter the frequency range in Hz.

Click the Show Frequency Response button to see the characteristics of the filter.

This will open the Digital Filter Frequency Response screen.
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The graph shows the magnitude of the signal at a given Hertz frequency (X-axis) in the color
blue. The phase of delay will be shown in red and is expressed in degrees (-180 to +180).
Check Magnitude: Show Decibels (dB) to show the magnitude in decibels. Check Phase:
show delay (MS) to show the delay in milliseconds.
DC Offset removal
This is a simple trend removal filter, much like a high pass filter, but simpler. It can be used
to neutralize the DC offset of a signal (e.g. in an ECG).

Get signal-copy

ABS: Absolute value

DC-EXG Offset & Drift correction

General signal processing
The following types of computation can be selected:
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Amplitude: Mean
The mean amplitude simply adds up all the sample values and divides the result by the
number (N) of samples.
Set the following parameters:

-

Epoch size: The size in seconds of the samples that should be analyzed.

Amplitude: RMS
This function computes the root-mean-square of a signal. The following parameters can be
set:

The automatic epoch size setting calculates the epoch size which is needed for the minimal selected
frequency. This setting is the optimal setting to keep the feedback delays as small as possible.

-

Epoch size: Is the size of the epoch used to compute the RMS amplitude.

The peak-peak (pk-pk) microvolt level is computed by taking the RMS and multiplying it with a factor
of 2 times the square root of 2.

Correct the RMS amplitude by clicking Correct Noise (RMS Zeroing).
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The RMS Offset & Noise Level Correction dialog box will appear.

The following options can be set:
- Disable zeroing and noise correction: disable zeroing and correction.
- Use standard EEG correction: Set the amount of ‘noise’ correction. By default for an
EEG based signal (band pass filtered) a 0.1 microvolt correction is set.
- Zeroing : enable and update correction: The software takes the mean noise level
from the signal and subtracts that from the RMS. That means that the total noise in
that band, will now be subtracted from the RMS. The minimum microvolt RMS level
will be 0.1.
In that case shorten all EMG electrodes (plus, minus and ground) of the relevant input and
choose the zeroing: enable and update function. This will obtain the average RMS noise level
and subtract it from the RMS level being computed/displayed. Note that the raw EMG
signals will never be affected and the RMS zeroing can always be undone.
A computed RMS amplitude will never be less than 0.1 microvolt. This is the lower limit of the RMS
levels computed by the software.

Pulse rate: BVP and EKG
These functions are generally used to compute the heart rate from a BVP (blood volume
pulse) signal or a ECG (electrocardiogram) signal. Set the following parameters:

Also set R-peak polarity:

Respiration rate
This function is used to compute the respiration rate based on the input of the respiration
sensor.
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Set the following parameters:

Amplitude: AVR
This will show the averaged rectified value of the EMG. The following parameters can be set:

Statistical trends
Set the following parameters:

Choose between skipping data outside the range or to include all data.

Enter the range of input data.
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Frequency analysis (FFT) functions
These functions are based on spectral analysis (FFT). Choose from the following functions:

When computing spectral analysis using an FFT the result will usually be an array of ‘bins’ for
each frequency which indicate the power or magnitude of the signal at that frequency.
Band pass amplitude
This function computes the amplitude (= magnitude) of a signal in the given band width.
(Band pass results in pk-pk).
Set the following subtype parameters:

Set the frequency:

With Key, a shortcut key can be defined for increasing or decreasing the band pass settings
in discrete steps of 0.25/0.5 Hz steps.
% power of band pass
This function computes the percentage of activity within a certain frequency band,
compared to the total power of the signal.
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Band pass power
This function computes the power of a signal in the given band width. (band pass results in
microvolts squared).
That means that when the FFT based band pass amplitude (amplitude = magnitude)
generates a result of 10 microvolts pk-pk, for the same bandwidth, the band pass power
would result in 100 microvolts squared.

Median frequency
This function computes the median frequency of a signal in the provided frequency band.
Dominant frequency
This function computes the dominant (or peak) frequency of a signal in the provided
frequency band.

Mean frequency
This function computes the mean frequency of a signal in the provided frequency band.
Logging function
Choose from the following logging functions:
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Threshold log
Set the following subtype parameters:

Reward counter log
Set the following subtype parameters:

Z-Score log
Set the following subtype parameters:

Trial baseline corrected value

Custom computation
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